summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-06-18 01:16:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-15 13:49:37 +0200
commita0bdd6dab7c5288d981d76e554980d0979576e5b (patch)
tree24a338a31754931b130e55114fe8c9f9f1dabea5
parent88c2dabd6520a41fab58f96a5483719c82350346 (diff)
lxappearance: update to 0.5.2
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch12
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch10
-rw-r--r--recipes-lxde/lxappearance/lxappearance_0.5.2.bb19
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch b/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch
new file mode 100644
index 0000000..381c8be
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch
@@ -0,0 +1,12 @@
+diff -auNr lxappearance-0.5.1.orig/src/cursor-theme.c lxappearance-0.5.1/src/cursor-theme.c
+--- lxappearance-0.5.1.orig/src/cursor-theme.c 2012-01-15 20:16:51.113223420 +0100
++++ lxappearance-0.5.1/src/cursor-theme.c 2012-01-15 20:17:17.017897756 +0100
+@@ -44,6 +44,8 @@
+ cursor = gdk_cursor_new(types[i]);
+ GdkPixbuf* pix = gdk_cursor_get_image(cursor);
+ gdk_cursor_unref(cursor);
++ if (pix == NULL)
++ continue;
+ gtk_list_store_insert_with_values(store, &it, -1, 0, pix, -1);
+ g_object_unref(pix);
+ }
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch b/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch
new file mode 100644
index 0000000..6d76a18
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch
@@ -0,0 +1,10 @@
+--- lxappearance-0.5.1/configure.ac~ 2011-07-29 16:50:18.000000000 +0200
++++ lxappearance-0.5.1/configure.ac 2012-08-12 16:52:52.000000000 +0200
+@@ -16,6 +16,7 @@
+
+ # Checks for programs.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ # AM_PROG_LIBTOOL
+
+ # Checks for libraries.
diff --git a/recipes-lxde/lxappearance/lxappearance_0.5.2.bb b/recipes-lxde/lxappearance/lxappearance_0.5.2.bb
new file mode 100644
index 0000000..0767eed
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance_0.5.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "LXDE GTK+ theme switcher"
+HOMEPAGE = "http://lxde.org/"
+SECTION = "x11"
+
+PR = "r2"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "gtk+"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz \
+ file://empty-cursor.patch \
+ file://lxappearance_missing_am_prog_cc_c_o.patch \
+"
+SRC_URI[md5sum] = "a088c6ef08fd25df7dc3be5b07168bbe"
+SRC_URI[sha256sum] = "a446aaad5572dd42845d41a20db76ca1fb1b93e3827db1bce243c9877e5996f4"
+
+inherit autotools gettext pkgconfig