summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2011-11-09 00:08:40 +0100
committerPeter Tworek <tworaz666@gmail.com>2011-11-09 00:08:40 +0100
commitbcf8b4d845b6ad47f89052c98f58a601e4517080 (patch)
treec4d59919236fde02dcdc7926aad71aea3b84364a
parenta93142ce57e5a3466fff41c004308aff2a89936d (diff)
Add obconf 2.0.3+git recipe.
-rw-r--r--recipes-lxde/obconf/files/obconf-lxde2
-rw-r--r--recipes-lxde/obconf/obconf_2.0.3+git.bb33
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-lxde/obconf/files/obconf-lxde b/recipes-lxde/obconf/files/obconf-lxde
new file mode 100644
index 0000000..8ab27d0
--- /dev/null
+++ b/recipes-lxde/obconf/files/obconf-lxde
@@ -0,0 +1,2 @@
+#!/bin/sh
+obconf --config-file lxde-rc.xml
diff --git a/recipes-lxde/obconf/obconf_2.0.3+git.bb b/recipes-lxde/obconf/obconf_2.0.3+git.bb
new file mode 100644
index 0000000..6701fb4
--- /dev/null
+++ b/recipes-lxde/obconf/obconf_2.0.3+git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Tool for configuring the Openbox window manager"
+HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
+SECTION = "x11"
+
+SRCREV = "500163e2c74cbbded0361574fd14d0a1168c1119"
+PR = "r1"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "gtk+ glib-2.0 libglade startup-notification"
+RDEPENDS = "openbox"
+
+SRC_URI = "git://git.openbox.org/dana/obconf;branch=master;protocol=git \
+ file://obconf-lxde"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/mime ${datadir}/mimelnk"
+
+inherit autotools pkgconfig gettext mime
+
+do_configure_prepend () {
+ autopoint || bbfatal "autopoint failed"
+}
+
+do_configure_append () {
+ sed -i -e "/^Exec/s:obconf.*$:obconf-lxde:" ${S}/${PN}.desktop || bbfatal "sed failed"
+}
+
+do_install_append () {
+ install -m 0755 ${WORKDIR}/obconf-lxde ${D}${bindir}/
+}