summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2012-01-15 20:25:50 +0100
committerPeter Tworek <tworaz666@gmail.com>2012-01-15 20:25:50 +0100
commitc77a7d93d74ad83631fc70f2eb87edaad558a3b5 (patch)
tree9c2b8fcbed42bb47bcd4d13909f4a8d7ce41a1a0
parent5a6c9bf5a0a598a45c9d5149c993743b86cb983e (diff)
Fix lxappearance crash when empty cursors are used.
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.1/empty-cursor.patch12
-rw-r--r--recipes-lxde/lxappearance/lxappearance_0.5.1.bb5
2 files changed, 16 insertions, 1 deletions
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.1/empty-cursor.patch b/recipes-lxde/lxappearance/lxappearance-0.5.1/empty-cursor.patch
new file mode 100644
index 0000000..381c8be
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.1/empty-cursor.patch
@@ -0,0 +1,12 @@
+diff -auNr lxappearance-0.5.1.orig/src/cursor-theme.c lxappearance-0.5.1/src/cursor-theme.c
+--- lxappearance-0.5.1.orig/src/cursor-theme.c 2012-01-15 20:16:51.113223420 +0100
++++ lxappearance-0.5.1/src/cursor-theme.c 2012-01-15 20:17:17.017897756 +0100
+@@ -44,6 +44,8 @@
+ cursor = gdk_cursor_new(types[i]);
+ GdkPixbuf* pix = gdk_cursor_get_image(cursor);
+ gdk_cursor_unref(cursor);
++ if (pix == NULL)
++ continue;
+ gtk_list_store_insert_with_values(store, &it, -1, 0, pix, -1);
+ g_object_unref(pix);
+ }
diff --git a/recipes-lxde/lxappearance/lxappearance_0.5.1.bb b/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
index aeb3470..5092cfe 100644
--- a/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
+++ b/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
@@ -2,12 +2,15 @@ DESCRIPTION = "LXDE GTK+ theme switcher"
HOMEPAGE = "http://lxde.org/"
SECTION = "x11"
+PR = "r1"
+
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gtk+"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz \
+ file://empty-cursor.patch"
SRC_URI[md5sum] = "34d157a7fe97ef0b93db8fab3f251e07"
SRC_URI[sha256sum] = "74e638257092201a572f1fcd4eb93c195c9fa75e27602662de542b002e6deade"