summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2011-11-09 00:09:46 +0100
committerPeter Tworek <tworaz666@gmail.com>2011-11-09 00:09:46 +0100
commite3e5ae055713afcc950323a9c55e3db71019abc2 (patch)
tree59c16b5a61d46b67a124769d627ecaf342ba197a
parentbcf8b4d845b6ad47f89052c98f58a601e4517080 (diff)
Add gcalctool 5.32.2 recipe.
-rw-r--r--recipes-gnome/gcalctool/gcalctool_5.32.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-gnome/gcalctool/gcalctool_5.32.2.bb b/recipes-gnome/gcalctool/gcalctool_5.32.2.bb
new file mode 100644
index 0000000..72fba2c
--- /dev/null
+++ b/recipes-gnome/gcalctool/gcalctool_5.32.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Powerful calculator for GNOME"
+HOMEPAGE = "http://calctool.sourceforge.net/"
+SECTION = "x11"
+
+PR = "r2"
+
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "gtk+ gnome-doc-utils"
+RDEPENDS = "glib-2.0-utils"
+
+SRC_URI = "http://download.gnome.org/sources/${PN}/5.32/${PN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "edc7227b9c9cf8c4114918b84dab11b6"
+SRC_URI[sha256sum] = "307b277785b656a45c37a77e891caaa4ff21e9919fd7ab58148874c98f4d37d2"
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF = "--disable-gnome"
+
+FILES_${PN} += "${datadir}/glib-2.0"
+
+pkg_postinst_${PN} () {
+if [ -n "$D" ]; then
+ exit 1
+fi
+
+glib-compile-schemas ${datadir}/glib-2.0/schemas
+}