summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-06-19 13:08:19 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 17:39:27 +0100
commitb40e5d56d22c49404723220779ae79799bb7bddf (patch)
treef462c09208a6355ad76e30ae7883aa93b20dc482
parentf842fcecd7984b5fd2b0011b72dd80355c213aa9 (diff)
lxtask: add gtk3 packageconfig and enable it
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-lxde/lxtask/lxtask_0.1.7.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-lxde/lxtask/lxtask_0.1.7.bb b/recipes-lxde/lxtask/lxtask_0.1.7.bb
index 1b5baf9..3364f8b 100644
--- a/recipes-lxde/lxtask/lxtask_0.1.7.bb
+++ b/recipes-lxde/lxtask/lxtask_0.1.7.bb
@@ -5,10 +5,18 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "virtual/libintl intltool-native gtk+ glib-2.0"
+DEPENDS = "virtual/libintl intltool-native glib-2.0"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxtask-${PV}.tar.xz"
SRC_URI[md5sum] = "eb2ad374e97c317e2f74d47b1e582303"
SRC_URI[sha256sum] = "f0b65a6b145856000383badafd14ab7944fd98e95c9efdc03474a5a7ff8630fe"
+PACKAGECONFIG ?= "gtk3"
+PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
+python __anonymous () {
+ depends = d.getVar("DEPENDS", d, 1)
+ if 'gtk3' not in d.getVar('PACKAGECONFIG', True):
+ d.setVar("DEPENDS", "%s gtk+" % depends)
+}
+
inherit autotools pkgconfig gettext