summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-01-25 15:16:49 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2017-01-26 19:11:04 +0100
commit9c1501dcb95a8601c8d1fad73c1fcae2886c0377 (patch)
tree8a93fbb071c2c3f899a5477d86079f356fc8b29e
parent92f007c5b9b6ab48433b2049c32fc26b056b9159 (diff)
lxterminal: don't error out on faulty config for man pages
configure checks for XML catalogs from the host installation. If missing the resulting man/Makefile will fail in do_compile. Workaround this by ignoring that the man page can not be built. On Ubuntu were this was observed the following installs the required dependencies: sudo apt-get install docbook-xsl Better still one would fix lxterminal's configure to pick up OE's catalogs. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-lxde/lxterminal/lxterminal/0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch30
-rw-r--r--recipes-lxde/lxterminal/lxterminal_git.bb5
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-lxde/lxterminal/lxterminal/0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch b/recipes-lxde/lxterminal/lxterminal/0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch
new file mode 100644
index 0000000..23c9d18
--- /dev/null
+++ b/recipes-lxde/lxterminal/lxterminal/0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch
@@ -0,0 +1,30 @@
+From 6a8e9ac7f01e92e8a06108753819dbd13eb2da74 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Wed, 25 Jan 2017 15:08:41 +0100
+Subject: [PATCH 2/2] man/Makefile.am: don't error out on missing man
+ dependency
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ man/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/man/Makefile.am b/man/Makefile.am
+index fd9fea0..54bb786 100644
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -20,9 +20,10 @@ else
+ $(man_MANS):
+ @echo ""
+ @echo "Error: you need to run configure with '--enable-man'"
++ @echo " and the right dependencies installed"
+ @echo " in order to regenerate man pages."
+ @echo ""
+- @false
++ @echo "man page was not built" > $(man_MANS)
+ endif
+
+
+--
+2.5.5
+
diff --git a/recipes-lxde/lxterminal/lxterminal_git.bb b/recipes-lxde/lxterminal/lxterminal_git.bb
index 9ea9cb6..2c745eb 100644
--- a/recipes-lxde/lxterminal/lxterminal_git.bb
+++ b/recipes-lxde/lxterminal/lxterminal_git.bb
@@ -6,7 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
DEPENDS = "gtk+3 vte glib-2.0 intltool-native xmlto-native"
-SRC_URI = "git://github.com/lxde/lxterminal.git;protocol=https"
+SRC_URI = " \
+ git://github.com/lxde/lxterminal.git;protocol=https \
+ file://0002-man-Makefile.am-don-t-error-out-on-missing-man-depen.patch \
+"
SRCREV = "2cea95a7a8c4179e862ac3cb5036bf4e8316fff7"
S = "${WORKDIR}/git"