summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-06-19 12:27:21 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 17:38:00 +0100
commitdb6feaa8e49b158d212367feb36087dd52abada1 (patch)
tree2ea67068c4456171365f22af52a026e4c6b56a5d
parentab3847f66e4a68b856bb84b7e4a03bfb5d257753 (diff)
lxappearance-obconf: add gtk3 packageconfig and enable it
While at it add missing depends reported by do_package_qa Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-lxde/lxappearance-obconf/lxappearance-obconf/window_border_broken_with_gtk3.patch34
-rw-r--r--recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb14
2 files changed, 46 insertions, 2 deletions
diff --git a/recipes-lxde/lxappearance-obconf/lxappearance-obconf/window_border_broken_with_gtk3.patch b/recipes-lxde/lxappearance-obconf/lxappearance-obconf/window_border_broken_with_gtk3.patch
new file mode 100644
index 0000000..32b6003
--- /dev/null
+++ b/recipes-lxde/lxappearance-obconf/lxappearance-obconf/window_border_broken_with_gtk3.patch
@@ -0,0 +1,34 @@
+Hide theme preview as it's broken with GTK+ 3
+https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/lxappearance-obconf-gtk3
+https://sourceforge.net/p/lxde/bugs/768/
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+--- lxappearance-obconf-0.2.3/src/obconf.glade.orig 2016-06-19 12:09:46.005536697 +0200
++++ lxappearance-obconf-0.2.3/src/obconf.glade 2016-06-19 12:09:51.977462436 +0200
+@@ -539,26 +539,6 @@
+ </packing>
+ </child>
+ <child>
+- <object class="GtkFrame" id="frame1">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="label_xalign">0</property>
+- <child>
+- <object class="GtkImage" id="preview">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- <property name="stock">gtk-missing-image</property>
+- </object>
+- </child>
+- <child type="label_item">
+- <placeholder/>
+- </child>
+- </object>
+- <packing>
+- <property name="expand">True</property>
+- <property name="fill">True</property>
+- <property name="position">1</property>
+- </packing>
+ </child>
+ </object>
+ <packing>
diff --git a/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb b/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
index 23bcfae..7fe66c6 100644
--- a/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
+++ b/recipes-lxde/lxappearance-obconf/lxappearance-obconf_0.2.3.bb
@@ -4,12 +4,22 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "intltool-native menu-cache lxappearance"
+DEPENDS = "intltool-native libcroco librsvg lxappearance menu-cache openbox"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxappearance-obconf-${PV}.tar.xz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxappearance-obconf-${PV}.tar.xz"
+# only needed for gtk3, applied unconditionally thow
+SRC_URI += "file://window_border_broken_with_gtk3.patch"
SRC_URI[md5sum] = "ae0076d489aa786f5d573f7ff592a4ab"
SRC_URI[sha256sum] = "3150b33b4b7beb71c1803aee2be21c94767d73b70dfc8d2bcaafe2650ea83149"
+PACKAGECONFIG ?= "gtk3"
+PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
+python __anonymous () {
+ depends = d.getVar("DEPENDS", d, 1)
+ if 'gtk3' not in d.getVar('PACKAGECONFIG', True):
+ d.setVar("DEPENDS", "%s gtk+" % depends)
+}
+
inherit autotools gettext pkgconfig
FILES_${PN} += "${datadir}/lxappearance/obconf/obconf.glade \