summaryrefslogtreecommitdiff
path: root/recipes-lxde/packagegroup
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-07-26 19:53:42 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-15 13:51:23 +0200
commitc4ca50fb1158457fb9dfabeaab478f55b1e9b936 (patch)
treeea5b5fa7b5b94f38f11b2154e894829b71da6711 /recipes-lxde/packagegroup
parentc0922dd6e65a228f8cae14273ddf7911fd6dcdde (diff)
lxde: use packagegroup instead of task
Diffstat (limited to 'recipes-lxde/packagegroup')
-rw-r--r--recipes-lxde/packagegroup/packagegroup-lxde-base.bb22
-rw-r--r--recipes-lxde/packagegroup/packagegroup-lxde-extended.bb20
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes-lxde/packagegroup/packagegroup-lxde-base.bb b/recipes-lxde/packagegroup/packagegroup-lxde-base.bb
new file mode 100644
index 0000000..a028177
--- /dev/null
+++ b/recipes-lxde/packagegroup/packagegroup-lxde-base.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "All packages required for base LXDE installation."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+inherit task
+
+RDEPENDS_${PN} = " \
+ lxappearance \
+ lxde-icon-theme \
+ lxde-common \
+ lxmenu-data \
+ lxpanel \
+ lxsession \
+ lxterminal \
+ pcmanfm \
+ openbox \
+ obconf \
+ hicolor-icon-theme \
+ gtk-theme-clearlooks \
+ "
diff --git a/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb b/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb
new file mode 100644
index 0000000..436c187
--- /dev/null
+++ b/recipes-lxde/packagegroup/packagegroup-lxde-extended.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "All packages required for full LXDE installation."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r0"
+
+inherit task
+
+RDEPENDS_${PN} = "\
+ task-lxde-base \
+ "
+
+RRECOMMENDS_${PN} = " \
+ gpicview \
+ lxtask \
+ lxinput \
+ lxshortcut \
+ lxpolkit \
+ "