summaryrefslogtreecommitdiff
path: root/recipes-lxde
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-06-18 13:54:08 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 17:35:23 +0100
commit2af46e0b924c286b0b4a968c9f8f249d45bdc124 (patch)
tree19b8e66ccd5d71c5b67b558eff61a97a6d9b3cc8 /recipes-lxde
parent9c816027d37f61b0d70fe26bb769e4398251b507 (diff)
lxterminal: add recipe which fetches from git
This builds for gtk3 and vte with API 2.91 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-lxde')
-rw-r--r--recipes-lxde/lxterminal/lxterminal_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-lxde/lxterminal/lxterminal_git.bb b/recipes-lxde/lxterminal/lxterminal_git.bb
new file mode 100644
index 0000000..d768e5a
--- /dev/null
+++ b/recipes-lxde/lxterminal/lxterminal_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Lightweight vte-based tabbed terminal emulator for LXDE"
+HOMEPAGE = "http://lxde.sf.net"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+DEPENDS = "gtk+3 vte glib-2.0 intltool-native"
+
+SRC_URI = "git://github.com/lxde/lxterminal.git;protocol=https"
+SRCREV = "2cea95a7a8c4179e862ac3cb5036bf4e8316fff7"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--enable-gtk3 --enable-man"
+
+FILES_${PN} += "${datadir}/icons/hicolor/128x128/apps/lxterminal.png"
+
+inherit autotools pkgconfig gettext
+