summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch136
-rw-r--r--recipes-lxde/gpicview/gpicview_0.2.5.bb9
-rw-r--r--recipes-lxde/images/core-image-lxde.bb36
-rw-r--r--recipes-lxde/lxtask/lxtask_0.1.10.bb (renamed from recipes-lxde/lxtask/lxtask_0.1.9.bb)4
5 files changed, 181 insertions, 6 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index c10df3b..21d5e90 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_PATTERN_lxde-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_lxde-layer = "7"
LAYERDEPENDS_lxde-layer = "core openembedded-layer"
-LAYERSERIES_COMPAT_lxde-layer = "warrior zeus"
+LAYERSERIES_COMPAT_lxde-layer = "dunfell gatesgarth"
diff --git a/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch b/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch
new file mode 100644
index 0000000..a1f97b3
--- /dev/null
+++ b/recipes-lxde/gpicview/gpicview/remove-gdk-x11.patch
@@ -0,0 +1,136 @@
+For xwayland gdk/gdkx.h does not work.
+Remove the more elaborate gf_display_get_workarea function and use only
+the fallback.
+--- ./src/working-area.c.orig 2016-02-20 22:38:31.000000000 +0000
++++ ./src/working-area.c 2020-01-07 13:37:47.023817524 +0000
+@@ -23,126 +23,11 @@
+ */
+
+ # include <gdk/gdk.h>
+-# include <gdk/gdkx.h>
+-# include <X11/Xlib.h>
+-# include <X11/Xutil.h>
+-# include <X11/Xatom.h>
+-
+-void get_working_area(GdkScreen* screen, GdkRectangle *rect);
+-
+-static gboolean gf_display_get_workarea(GdkScreen* g_screen, GdkRectangle *rect) {
+- Atom xa_desktops, xa_current, xa_workarea, xa_type;
+- Display *x_display;
+- Window x_root;
+- guint32 desktops = 0, current = 0;
+- gulong *workareas, len, fill;
+- guchar *data;
+- gint format;
+-
+- GdkDisplay *g_display;
+- Screen *x_screen;
+-
+- /* get the gdk display */
+- g_display = gdk_display_get_default();
+- if(!g_display)
+- return FALSE;
+-
+- /* get the x display from the gdk display */
+- x_display = gdk_x11_display_get_xdisplay(g_display);
+- if(!x_display)
+- return FALSE;
+-
+- /* get the x screen from the gdk screen */
+- x_screen = gdk_x11_screen_get_xscreen(g_screen);
+- if(!x_screen)
+- return FALSE;
+-
+- /* get the root window from the screen */
+- x_root = XRootWindowOfScreen(x_screen);
+-
+- /* find the _NET_NUMBER_OF_DESKTOPS atom */
+- xa_desktops = XInternAtom(x_display, "_NET_NUMBER_OF_DESKTOPS", True);
+- if(xa_desktops == None)
+- return FALSE;
+-
+- /* get the number of desktops */
+- if(XGetWindowProperty(x_display, x_root, xa_desktops, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- desktops = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_CURRENT_DESKTOP atom */
+- xa_current = XInternAtom(x_display, "_NET_CURRENT_DESKTOP", True);
+- if(xa_current == None)
+- return FALSE;
+-
+- /* get the current desktop */
+- if(XGetWindowProperty(x_display, x_root, xa_current, 0, 1, False,
+- XA_CARDINAL, &xa_type, &format, &len, &fill,
+- &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- if(!data)
+- return FALSE;
+-
+- current = *(guint32 *)data;
+- XFree(data);
+-
+- /* find the _NET_WORKAREA atom */
+- xa_workarea = XInternAtom(x_display, "_NET_WORKAREA", True);
+- if(xa_workarea == None)
+- return FALSE;
+-
+- if(XGetWindowProperty(x_display, x_root, xa_workarea, 0, (glong)(4 * 32),
+- False, AnyPropertyType, &xa_type, &format, &len,
+- &fill, &data) != Success)
+- {
+- return FALSE;
+- }
+-
+- /* make sure the type and format are good */
+- if(xa_type == None || format == 0)
+- return FALSE;
+-
+- /* make sure we don't have any leftovers */
+- if(fill)
+- return FALSE;
+-
+- /* make sure len divides evenly by 4 */
+- if(len % 4)
+- return FALSE;
+-
+- /* it's good, lets use it */
+- workareas = (gulong *)(guint32 *)data;
+-
+- rect->x = (guint32)workareas[current * 4];
+- rect->y = (guint32)workareas[current * 4 + 1];
+- rect->width = (guint32)workareas[current * 4 + 2];
+- rect->height = (guint32)workareas[current * 4 + 3];
+-
+- /* clean up our memory */
+- XFree(data);
+-
+- return TRUE;
+-}
+
+ void get_working_area(GdkScreen* screen, GdkRectangle *rect)
+ {
+- if( !gf_display_get_workarea(screen, rect) )
+- {
+- rect->x = 0;
+- rect->y = 0;
+- rect->width = gdk_screen_width();
+- rect->height = gdk_screen_height();
+- }
++ rect->x = 0;
++ rect->y = 0;
++ rect->width = gdk_screen_width();
++ rect->height = gdk_screen_height();
+ }
diff --git a/recipes-lxde/gpicview/gpicview_0.2.5.bb b/recipes-lxde/gpicview/gpicview_0.2.5.bb
index c6061b2..cee82b7 100644
--- a/recipes-lxde/gpicview/gpicview_0.2.5.bb
+++ b/recipes-lxde/gpicview/gpicview_0.2.5.bb
@@ -5,10 +5,13 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-DEPENDS = "glib-2.0-native gtk+ intltool-native jpeg"
+DEPENDS = "glib-2.0-native intltool-native jpeg"
RDEPENDS_${PN} = "adwaita-icon-theme"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz"
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz \
+ file://remove-gdk-x11.patch \
+"
SRC_URI[md5sum] = "26be9b0c5a234f1afe7d83d02a4a33f4"
SRC_URI[sha256sum] = "38466058e53702450e5899193c4b264339959b563dd5cd81f6f690de32d82942"
@@ -16,6 +19,6 @@ PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk2] = ",,gtk+"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
-inherit autotools gettext pkgconfig
+inherit autotools gettext mime-xdg pkgconfig
FILES_${PN} += "${datadir}/icons/*"
diff --git a/recipes-lxde/images/core-image-lxde.bb b/recipes-lxde/images/core-image-lxde.bb
new file mode 100644
index 0000000..3356f8c
--- /dev/null
+++ b/recipes-lxde/images/core-image-lxde.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Image with the LXDE desktop environment"
+export IMAGE_BASENAME = "core-image-lxde"
+
+LICENSE = "MIT"
+
+# Most LXDE components don't even compile without native X11 support,
+# (gdk-x11), so make this fail early if x11 is provided by XWAYLAND.
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+CONFLICT_DISTRO_FEATURES = "wayland"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+IMAGE_LINGUAS = " "
+
+IMAGE_INSTALL += " \
+ packagegroup-core-boot \
+ packagegroup-core-x11 \
+ packagegroup-lxde-extended \
+ kernel-modules \
+ \
+ lxdm \
+ \
+ openbox \
+ openbox-theme-clearlooks \
+ openbox-theme-onyx \
+ obconf \
+ hicolor-icon-theme \
+"
+
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "systemd"
+IMAGE_INITSCRIPTS = " "
+IMAGE_LOGIN_MANAGER = "busybox shadow"
+
+inherit core-image
diff --git a/recipes-lxde/lxtask/lxtask_0.1.9.bb b/recipes-lxde/lxtask/lxtask_0.1.10.bb
index aea3a67..fa30ec3 100644
--- a/recipes-lxde/lxtask/lxtask_0.1.9.bb
+++ b/recipes-lxde/lxtask/lxtask_0.1.10.bb
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "glib-2.0 glib-2.0-native intltool-native virtual/libintl"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/lxtask-${PV}.tar.xz"
-SRC_URI[md5sum] = "f19a9e4d22a075f984681a480f0aa886"
-SRC_URI[sha256sum] = "41ea88f0adf31a840e4b9d137ca5ea802860d1a117845ba25f3080d74a876433"
+SRC_URI[md5sum] = "27b5258847afc237a5b89666e7a8b45b"
+SRC_URI[sha256sum] = "2216df9bc4bb2d80733e788966512ac58c421e0a0a1ff85210f34a29d1eb4e2c"
PACKAGECONFIG ?= "gtk3"
PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"