summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-08-15 18:39:37 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-22 02:00:29 +0100
commitf18124fad8437cd480d3de1051e1610bd1aae878 (patch)
treee94e19aae274cee4c54f7d0e562d6e1c8bc98728
parent6e4938ecc83e84e490fab7d014a6d56f0b9d37ed (diff)
snapd: compile with arm instruction set
When compiling for thumb one gets errors like this: | ../recipe-sysroot-native/usr/lib/arm-angstrom-linux-gnueabi/go/pkg/tool/linux_amd64/link \ | -o $WORK/github.com/snapcore/snapd/cmd/snap/_obj/exe/a.out -L $WORK \ | -L .../recipe-sysroot/usr/lib/arm-angstrom-linux-gnueabi/go/pkg/linux_arm \ | -extld=arm-angstrom-linux-gnueabi-gcc "-extldflags=-march=armv7-a -mthumb \ | -mfpu=neon -mfloat-abi=hard --sysroot=.../recipe-sysroot" -buildmode=exe \ | -buildid=e86c00f573bc1df95256a4a05d36066839bfed34 $WORK/github.com/snapcore/snapd/cmd/snap.a | # github.com/snapcore/snapd/cmd/snap | /tmp/go-build238845398/os/user.a(_all.o): unknown relocation type 30; compiled without -fpic? | invalid rela size 1 | /tmp/go-build238845398/net.a(_all.o): unknown relocation type 30; compiled without -fpic? | invalid rela size 1 | ... Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-support/snapd/snapd_2.25.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-support/snapd/snapd_2.25.bb b/recipes-support/snapd/snapd_2.25.bb
index 1923e8a..303dfee 100644
--- a/recipes-support/snapd/snapd_2.25.bb
+++ b/recipes-support/snapd/snapd_2.25.bb
@@ -28,6 +28,8 @@ RDEPENDS_${PN} += " \
S = "${WORKDIR}/${PN}-${PV}"
+ARM_INSTRUCTION_SET = "arm"
+
EXTRA_OECONF += " \
--disable-apparmor \
--disable-seccomp \