summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-12-09 13:23:41 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-12-09 14:26:21 +0100
commita34959eb0d938c292bef1283797dc0ee5dd39ccd (patch)
tree9253db606610dec66eef4d32bdab9f99e9b34992
parent85b545d926f67972a4ab2a30da498392cd1092b3 (diff)
Revert "systemd: add boot.mount"
Revert in favor of fstab + udev automount. This reverts commit 2554f4eec62d2cd68dec3d043654874f3b221e63. Compare with commit 38705bd ("fstab: configure the emmc's first partition to mount at /boot") in meta-toradex-demos. Related-to: ELB-3250 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-core/systemd/systemd/boot.mount11
-rw-r--r--recipes-core/systemd/systemd_%.bbappend15
2 files changed, 1 insertions, 25 deletions
diff --git a/recipes-core/systemd/systemd/boot.mount b/recipes-core/systemd/systemd/boot.mount
deleted file mode 100644
index 25dedd5..0000000
--- a/recipes-core/systemd/systemd/boot.mount
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Boot partition
-
-[Install]
-WantedBy=default.target
-
-[Mount]
-What=/dev/disk/by-label/BOOT
-Where=/boot
-Options=rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro
-TimeoutSec=3
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 00e69cd..ea40849 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,17 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://boot.mount"
-
-do_install_append() {
- install -m 0644 ${WORKDIR}/boot.mount ${D}${systemd_unitdir}/system/
- install -d ${D}${sysconfdir}/systemd/system/default.target.wants
- ln -sf ${systemd_unitdir}/system/boot.mount \
- ${D}${sysconfdir}/systemd/system/default.target.wants/boot.mount
-}
-
# This allows for udevd automounting with mounts accessible to all.
do_configure_prepend () {
sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
-}
-
-FILES_${PN} += "${sysconfdir}/systemd/system/default.target.wants/*.mount"
-FILES_${PN} += "${base_libdir}/systemd/system/*.mount"
+} \ No newline at end of file