summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-10-29 22:33:55 +0100
committerMax Krummenacher <max.oss.09@gmail.com>2015-10-30 10:46:57 +0100
commit2c7ed40370ee2c9bccdac1a7f97a4b50cf904d88 (patch)
tree185d39fc8df1dc3943cdb5674801c1c6eb32620d
parentfbb39dd06744ebd9ca0e18e7889d11733d4f00d6 (diff)
chromium: remove outdated bbappend
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/armv7a/include.gypi14
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/armv7a/oe-defaults.gypi19
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/chromium_arm_build.patch23
-rw-r--r--recipes-browser/chromium/chromium-24.0.1312.52/h264_enablement.patch35
-rw-r--r--recipes-browser/chromium/chromium_24.0.1312.52.bbappend21
5 files changed, 0 insertions, 112 deletions
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/include.gypi b/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/include.gypi
deleted file mode 100644
index bec8cfe..0000000
--- a/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/include.gypi
+++ /dev/null
@@ -1,14 +0,0 @@
-{
- 'variables': {
- # Configure for armv7 compilation
- 'target_arch': 'arm',
- 'armv7': 1,
- 'arm_thumb': 1,
- #'arm_neon': 1,
- 'arm_fpu': 'vfpv3-d16',
- 'arm_float_abi': 'hard',
- 'v8_use_arm_eabi_hardfloat': 'true',
- 'v8_target_arch' : 'arm',
- 'disable_sse2' : 1,
- },
-}
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/oe-defaults.gypi b/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/oe-defaults.gypi
deleted file mode 100644
index 8b23d1d..0000000
--- a/recipes-browser/chromium/chromium-24.0.1312.52/armv7a/oe-defaults.gypi
+++ /dev/null
@@ -1,19 +0,0 @@
-{
- 'variables': {
- 'use_system_bzip2': 1,
- 'disable_nacl': 1,
- 'proprietary_codecs': 1,
- 'v8_use_snapshot': 1,
- 'use_system_ffmpeg': 0,
- 'linux_use_tcmalloc': 0,
- 'linux_link_kerberos': 0,
- 'use_kerberos': 0,
- 'use_cups': 0,
- 'use_gnome_keyring': 0,
- 'linux_link_gnome_keyring': 0,
- 'use_third_party_translations': 1,
- 'werror': '',
- 'OS': 'linux',
- 'ffmpeg_branding': 'ChromeOS',
- },
-}
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/chromium_arm_build.patch b/recipes-browser/chromium/chromium-24.0.1312.52/chromium_arm_build.patch
deleted file mode 100644
index d415ec5..0000000
--- a/recipes-browser/chromium/chromium-24.0.1312.52/chromium_arm_build.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur chromium-24.0.1312.52.orig/crypto/nss_util.cc chromium-24.0.1312.52/crypto/nss_util.cc
---- chromium-24.0.1312.52.orig/crypto/nss_util.cc 2013-01-08 03:40:36.000000000 +0100
-+++ chromium-24.0.1312.52/crypto/nss_util.cc 2013-06-12 22:42:40.154057157 +0200
-@@ -665,6 +665,7 @@
-
- // For Debian derivatives NSS libraries are located here.
- paths.push_back(FilePath("/usr/lib/nss"));
-+ paths.push_back(FilePath("/usr/lib"));
-
- // Ubuntu 11.10 (Oneiric) places the libraries here.
- #if defined(ARCH_CPU_X86_64)
-diff -Naur chromium-24.0.1312.52.orig/media/filters/decrypting_audio_decoder.cc chromium-24.0.1312.52/media/filters/decrypting_audio_decoder.cc
---- chromium-24.0.1312.52.orig/media/filters/decrypting_audio_decoder.cc 2013-01-08 03:40:10.000000000 +0100
-+++ chromium-24.0.1312.52/media/filters/decrypting_audio_decoder.cc 2013-06-12 22:39:56.798055413 +0200
-@@ -30,7 +30,7 @@
- // Out of sync of 100ms would be pretty noticeable and we should keep any
- // drift below that.
- const int64 kOutOfSyncThresholdInMicroseconds = 100000;
-- return std::abs(timestamp_1.InMicroseconds() - timestamp_2.InMicroseconds()) >
-+ return abs(timestamp_1.InMicroseconds() - timestamp_2.InMicroseconds()) >
- kOutOfSyncThresholdInMicroseconds;
- }
-
diff --git a/recipes-browser/chromium/chromium-24.0.1312.52/h264_enablement.patch b/recipes-browser/chromium/chromium-24.0.1312.52/h264_enablement.patch
deleted file mode 100644
index c3d5347..0000000
--- a/recipes-browser/chromium/chromium-24.0.1312.52/h264_enablement.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -Naur chromium-24.0.1312.52.orig/content/common/gpu/media/gles2_texture_to_egl_image_translator.cc chromium-24.0.1312.52/content/common/gpu/media/gles2_texture_to_egl_image_translator.cc
---- chromium-24.0.1312.52.orig/content/common/gpu/media/gles2_texture_to_egl_image_translator.cc 2013-01-08 03:40:32.000000000 +0100
-+++ chromium-24.0.1312.52/content/common/gpu/media/gles2_texture_to_egl_image_translator.cc 2013-06-12 22:50:03.949061900 +0200
-@@ -3,6 +3,7 @@
- // found in the LICENSE file.
-
- #include "content/common/gpu/media/gles2_texture_to_egl_image_translator.h"
-+#define TOOLKIT_USES_GTK
-
- #include "base/logging.h"
- #if defined(TOOLKIT_USES_GTK)
-diff -Naur chromium-24.0.1312.52.orig/content/content_common.gypi chromium-24.0.1312.52/content/content_common.gypi
---- chromium-24.0.1312.52.orig/content/content_common.gypi 2013-01-08 03:40:34.000000000 +0100
-+++ chromium-24.0.1312.52/content/content_common.gypi 2013-06-15 20:51:16.920211604 +0200
-@@ -465,7 +465,7 @@
- '../gpu/gpu.gyp:command_buffer_service',
- ],
- }],
-- ['target_arch=="arm" and chromeos == 1', {
-+ ['target_arch=="arm" and (OS=="linux" or chromeos == 1)', {
- 'dependencies': [
- '../media/media.gyp:media',
- ],
-diff -Naur chromium-24.0.1312.52.orig/content/content_gpu.gypi chromium-24.0.1312.52/content/content_gpu.gypi
---- chromium-24.0.1312.52.orig/content/content_gpu.gypi 2013-01-08 03:40:34.000000000 +0100
-+++ chromium-24.0.1312.52/content/content_gpu.gypi 2013-06-12 22:51:04.485062547 +0200
-@@ -100,7 +100,7 @@
- '../third_party/libXNVCtrl/libXNVCtrl.gyp:libXNVCtrl',
- ],
- }],
-- ['target_arch=="arm" and chromeos == 1', {
-+ ['target_arch=="arm" and (OS=="linux" or chromeos == 1)', {
- 'include_dirs': [
- '<(DEPTH)/third_party/openmax/il',
- ],
diff --git a/recipes-browser/chromium/chromium_24.0.1312.52.bbappend b/recipes-browser/chromium/chromium_24.0.1312.52.bbappend
deleted file mode 100644
index 1e16e7a..0000000
--- a/recipes-browser/chromium/chromium_24.0.1312.52.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/chromium-${PV}:"
-
-EXTRA_OEGYP_prepend = "-DUSE_EABI_HARDFLOAT=1"
-
-SRC_URI += " \
- file://chromium_arm_build.patch \
- file://h264_enablement.patch \
-"
-
-FILES_${PN} += " \
- ${libdir}/libOmxCore.so \
-"
-
-#we have a symlinks ending in .so, skip QA ldflags for this package
-INSANE_SKIP_${PN} = "dev-so ldflags"
-
-do_install_append () {
- #make a symlink with the standard soname of the OpenMax component
- install -d ${D}/${libdir}
- ln -s libnvomx.so ${D}/${libdir}/libOmxCore.so
-}