summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-08-17 13:33:56 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:35:15 +0200
commitc851ea090db8728865ef50ab34294c66374574f1 (patch)
tree929e6eca0d0059c712f86a1985da853ed710c368
parent486e44202519c9a4e58d5ccb0572d2473255fbac (diff)
add layer.conf
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--conf/layer.conf18
1 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..2c63546
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,18 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "toradex-bsp-common-layer"
+BBFILE_PATTERN_toradex-bsp-common-layer = "^${LAYERDIR}/"
+BBFILE_PRIORITY_toradex-bsp-common-layer = "90"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"