summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2019-08-10 09:53:59 +0800
committerMing Liu <ming.liu@toradex.com>2019-08-11 17:27:50 +0800
commit11279aebde7d65d67d4ec13b2ae2862e20a595fa (patch)
tree07035567c502f61bb3b8eaa12f76e2545d97e2cc
parent8a3847fbbf9cfad90919a99878b3df2e11389f24 (diff)
u-boot-distro-boot: some clean up
- Inherit nopackages since it does not generate any non-empty packages. - Drop do_compile, we can run mkimage directly in do_deploy task. - Drop 'S = "${WORKDIR}"', we do not have to explicitly set it, the default S would be good enough. - Do not install DEPLOYDIR, that is not necessary, it's already done in deploy.bbclass. - Do not set noexec flag to do_install, do_populate_sysroot, they are basically empty tasks, making do_populate_sysroot noexec also will cause QA warning when u-boot-distro-boot is set to DEPENDS in other recipes. Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 474ec66..f7a5ae9 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -12,24 +12,16 @@ SRC_URI = " \
KERNEL_BOOTCMD ??= "bootz"
KERNEL_BOOTCMD_aarch64 ?= "booti"
-S = "${WORKDIR}"
+inherit deploy nopackages
-inherit deploy
-
-do_compile() {
+do_deploy() {
sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
"${WORKDIR}/boot.cmd.in" > boot.cmd
- mkimage -T script -C none -n "Distro boot script" -d "${WORKDIR}/boot.cmd" boot.scr
-}
+ mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr
-do_deploy() {
- install -d ${DEPLOYDIR}
install -m 0644 boot.scr ${DEPLOYDIR}
}
addtask deploy after do_install before do_build
-do_install[noexec] = "1"
-do_populate_sysroot[noexec] = "1"
-
PACKAGE_ARCH = "${MACHINE_ARCH}"