summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-04-06 16:21:05 +0300
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-05-15 02:32:48 +0200
commit334412e77bd57ca332d01b3aa7986587bfdc40cc (patch)
tree78a5ee8753b0599491e54dc036da66d4d2d1178e
parent6c5ec7934f40e4a352f0ebf2ff747358a2a264f4 (diff)
hostapd: upgrade to version 2.9
Upgrade the hostapd to sync with wpa_supplicant 2.9. Related-to: ELB-2724 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
-rw-r--r--recipes-connectivity/hostapd/hostapd/defconfig11
-rw-r--r--recipes-connectivity/hostapd/hostapd_2.9.bb (renamed from recipes-connectivity/hostapd/hostapd_2.7.bb)36
2 files changed, 23 insertions, 24 deletions
diff --git a/recipes-connectivity/hostapd/hostapd/defconfig b/recipes-connectivity/hostapd/hostapd/defconfig
index fd01198..a62bec4 100644
--- a/recipes-connectivity/hostapd/hostapd/defconfig
+++ b/recipes-connectivity/hostapd/hostapd/defconfig
@@ -139,15 +139,10 @@ CONFIG_DRIVER_RADIUS_ACL=y
# IEEE 802.11n (High Throughput) support
CONFIG_IEEE80211N=y
+# IEEE 802.11ac (Very High Throughput) support
+CONFIG_IEEE80211AC=y
+
# Remove debugging code that is printing out debug messages to stdout.
# This can be used to reduce the size of the hostapd considerably if debugging
# code is not needed.
#CONFIG_NO_STDOUT_DEBUG=y
-
-# IEEE 802.11ac (Very High Throughput) supportĀ¬
-CONFIG_IEEE80211AC=y
-
-# Build IPv6 support for RADIUS operationsĀ¬
-CONFIG_IPV6=y
-
-
diff --git a/recipes-connectivity/hostapd/hostapd_2.7.bb b/recipes-connectivity/hostapd/hostapd_2.9.bb
index d0cf7d0..e26a6ff 100644
--- a/recipes-connectivity/hostapd/hostapd_2.7.bb
+++ b/recipes-connectivity/hostapd/hostapd_2.9.bb
@@ -1,15 +1,10 @@
+SUMMARY = "User space daemon for extended IEEE 802.11 management"
HOMEPAGE = "http://w1.fi/hostapd/"
SECTION = "kernel/userland"
-LICENSE = "GPLv2 | BSD"
-LIC_FILES_CHKSUM = "file://${B}/README;md5=9f542dba9d227d1a51f4405a415cc2b2"
-DEPENDS = "libnl openssl"
-SUMMARY = "User space daemon for extended IEEE 802.11 management"
-
-inherit update-rc.d systemd
-INITSCRIPT_NAME = "hostapd"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://hostapd/README;md5=1ec986bec88070e2a59c68c95d763f89"
-SYSTEMD_SERVICE_${PN} = "hostapd.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+DEPENDS = "libnl openssl"
SRC_URI = " \
http://w1.fi/releases/hostapd-${PV}.tar.gz \
@@ -18,16 +13,29 @@ SRC_URI = " \
file://hostapd.service \
"
+SRC_URI[md5sum] = "f188fc53a495fe7af3b6d77d3c31dee8"
+SRC_URI[sha256sum] = "881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7"
+
S = "${WORKDIR}/hostapd-${PV}"
B = "${WORKDIR}/hostapd-${PV}/hostapd"
-do_configure() {
+inherit update-rc.d systemd pkgconfig distro_features_check
+
+CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers"
+
+INITSCRIPT_NAME = "hostapd"
+
+SYSTEMD_SERVICE_${PN} = "hostapd.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+do_configure_append() {
install -m 0644 ${WORKDIR}/defconfig ${B}/.config
}
do_compile() {
- export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
- make
+ export CFLAGS="-MMD -O2 -Wall -g"
+ export EXTRA_CFLAGS="${CFLAGS}"
+ make V=1
}
do_install() {
@@ -41,7 +49,3 @@ do_install() {
}
CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
-
-SRC_URI[md5sum] = "8d3799f3a3c247cff47d41503698721b"
-SRC_URI[sha256sum] = "21b0dda3cc3abe75849437f6b9746da461f88f0ea49dd621216936f87440a141"
-