summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-04-14 23:50:19 +0300
committerOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-04-15 01:07:00 +0300
commit56887d44144c03781d6d08d015ddb3949ca1e03d (patch)
tree84b919712ab7bb2e1474e00111ef13d545e5162b
parentce4619fdc1f2c1c6fcf3b54eaa6fc3bf1d23106c (diff)
backports: fix loading rtl8188eu for colibri-imx8x
With common depmod config file, the backported rtl8188eu driver tries to load for Realtek 8188EU USB devices. On the other hand, on-module Wi-Fi chip loads built-in mwifiex_pcie driver. This driver uses cfg80211 built-in module. Backported rtl8188eu driver can't use built-in cfg80211 module, so to allow using Realtek 8188EU USB device with Colibri iMX8QXP module, the built-in rtl8188eu driver should be used. With this patch the specific depmod config file deploys on the image for Colibri iMX8QXP. Related-to: ELB-2687 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
-rw-r--r--recipes-kernel/backports/backports_5.4.bb8
-rw-r--r--recipes-kernel/backports/files/colibri-imx8x/99-backports.conf8
2 files changed, 13 insertions, 3 deletions
diff --git a/recipes-kernel/backports/backports_5.4.bb b/recipes-kernel/backports/backports_5.4.bb
index 5da78be..4d74c62 100644
--- a/recipes-kernel/backports/backports_5.4.bb
+++ b/recipes-kernel/backports/backports_5.4.bb
@@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
inherit module-base
+DEPMOD_CONF = "99-backports.conf"
+
# To generate the backports tree yourself, so you can make modifications:
# Generate the backport tree using:
# git clone git://git.toradex.com/backports-sources-toradex.git -b linux-5.4.y
@@ -19,7 +21,7 @@ SRCREV_use-head-next = "${AUTOREV}"
SRC_URI = " \
git://git.toradex.com/backports-toradex.git;protocol=git;branch=toradex-${PV} \
file://config \
- file://99-backports.conf \
+ file://${DEPMOD_CONF} \
"
# Depend on virtual/kernel to ensure that the kernel is built before we try to
@@ -52,7 +54,7 @@ do_compile() {
do_install() {
install -d ${D}/etc/depmod.d/
- install -m 0644 ${WORKDIR}/99-backports.conf ${D}/etc/depmod.d/
+ install -m 0644 ${WORKDIR}/${DEPMOD_CONF} ${D}/etc/depmod.d/${DEPMOD_CONF}
install -d ${D}/lib/modules/${KERNEL_VERSION}/backports
for ko in $(find ${S} -type f -name "*.ko")
@@ -78,6 +80,6 @@ pkg_postrm_${PN} () {
}
FILES_${PN} = " \
- /etc/depmod.d/99-backports.conf \
+ /etc/depmod.d/${DEPMOD_CONF} \
/lib/modules/${KERNEL_VERSION}/backports/ \
"
diff --git a/recipes-kernel/backports/files/colibri-imx8x/99-backports.conf b/recipes-kernel/backports/files/colibri-imx8x/99-backports.conf
new file mode 100644
index 0000000..525b827
--- /dev/null
+++ b/recipes-kernel/backports/files/colibri-imx8x/99-backports.conf
@@ -0,0 +1,8 @@
+search built-in backports
+
+override mwifiex_sdio * backports
+override mwifiex_usb * backports
+
+override r8188eu * built-in
+override mwifiex_pcie * built-in
+override hostap * built-in