summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2018-11-13 18:41:22 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-04 17:09:52 +0100
commit1669a9c8a31c5fd7bee67cd6c9f75fac9fe12515 (patch)
tree9c342afd2375bd9d6ee97dee12648881fa59e803
parent73a0e3a3225d8cf48b3c8d313f7d561c47b9cc18 (diff)
tezi-metadata: inherit nopackages
A main package being empty without setting ALLOW_EMPTY can lead to errors in populate_sdk task. If it does not provide any packages then we should let it inherit nopackages bbclass. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb b/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
index b03cab5..fdebcd6 100644
--- a/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
+++ b/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
file://marketing.tar;unpack=false \
"
-inherit deploy
+inherit deploy nopackages
do_deploy () {
install -m 644 ${WORKDIR}/prepare.sh ${DEPLOYDIR}
@@ -18,7 +18,7 @@ do_deploy () {
install -m 644 ${WORKDIR}/marketing.tar ${DEPLOYDIR}
}
-addtask deploy before do_package after do_install
+addtask deploy before do_build after do_install
COMPATIBLE_MACHINE = "(apalis-imx6|apalis-t30|apalis-tk1|colibri-imx6|colibri-imx7)"