summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-06-19 14:04:11 +0300
committerOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-06-19 14:07:17 +0300
commite0beff9f048259b24b147b21f49c1463ebd70511 (patch)
treeb3ccbb66d2d09ce71fc19e8160720d14b7ad9b75
parentb8b2e862432c0a30f41bd19efb66ec80267e7f5d (diff)
linux-toradex-mainline: fix adding symbols to dtb files
There is a dead code in the linux-toradex-mainline.inc, that doesn't really install dtb files into the final image. Remove this code add add the option to compile dtb files with symbols in the proper place. Related-to: ELB-2797 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc6
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_%.bbappend1
2 files changed, 1 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
index 37bc7f3..ceea4f5 100644
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ b/recipes-kernel/linux/linux-toradex-mainline.inc
@@ -23,12 +23,6 @@ kernel_do_configure_append_preempt-rt() {
oe_runmake olddefconfig
}
-do_install_append() {
- install -d ${D}/boot
- make -C ${S} O=${B} ARCH=$ARCH DTC_FLAGS="-@" dtbs || true
- install -m 0644 "${B}/arch/$ARCH/boot/dts/*.dtb" ${D}/boot || true
-}
-
# Additional file deployed by recent mainline kernels
FILES_${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
diff --git a/recipes-kernel/linux/linux-toradex-mainline_%.bbappend b/recipes-kernel/linux/linux-toradex-mainline_%.bbappend
new file mode 100644
index 0000000..a4bc867
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline_%.bbappend
@@ -0,0 +1 @@
+EXTRA_OEMAKE += "DTC_FLAGS=-@ "