summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2020-07-08 14:24:35 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-08-06 10:55:55 +0200
commit6dc9339b57458519c1b80d1ebee334b75717b892 (patch)
tree44aa5e61db2986673a6955a072c7e59442d280b0
parent122c8b8fae28472b3b13c2bbef6c02325cbfcb96 (diff)
recipes-core: udev: add systemd link file to disable wifi-if-renaming
Related-to: ELB-2760 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com> (cherry picked from commit fc137a7916fe004f476688b1e03dadd074e749b3)
-rw-r--r--recipes-core/udev/files/10-toradex-wifi-ifnames.link6
-rw-r--r--recipes-core/udev/udev-toradex-rules.bb3
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/udev/files/10-toradex-wifi-ifnames.link b/recipes-core/udev/files/10-toradex-wifi-ifnames.link
new file mode 100644
index 0000000..35d5d20
--- /dev/null
+++ b/recipes-core/udev/files/10-toradex-wifi-ifnames.link
@@ -0,0 +1,6 @@
+[Match]
+Driver=mwifiex_pcie
+
+[Link]
+NamePolicy=keep kernel
+
diff --git a/recipes-core/udev/udev-toradex-rules.bb b/recipes-core/udev/udev-toradex-rules.bb
index 9cc69a9..dc6248a 100644
--- a/recipes-core/udev/udev-toradex-rules.bb
+++ b/recipes-core/udev/udev-toradex-rules.bb
@@ -3,9 +3,12 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "\
file://99-toradex.rules \
+ file://10-toradex-wifi-ifnames.link \
"
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
+ install -d ${D}${sysconfdir}/systemd/network
install -m 0644 ${WORKDIR}/99-toradex.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${WORKDIR}/10-toradex-wifi-ifnames.link ${D}${sysconfdir}/systemd/network/
}