summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-07-14 18:31:18 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-08-27 19:32:54 +0200
commit8b4f064fc58a30a1acb807aa34a70dbfa5bc5f08 (patch)
tree082549f4587a92e9618a87c88a304a18714e6d40
parent1914b33f70f13b5460152daaf49de7511e4990ee (diff)
systemd: replace patch with sed script
the configuration file keeps beeing changed with each version requiring a refresh of the patch frequently. Replace the patch with a sed script which should be more stable. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch25
-rw-r--r--recipes-core/systemd/systemd_%.bbappend9
2 files changed, 4 insertions, 30 deletions
diff --git a/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch b/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
deleted file mode 100644
index 12a373b..0000000
--- a/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 81f13a95f56b98f597d4005a246a8813fe93d9c1 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.oss.09@gmail.com>
-Date: Thu, 29 Oct 2015 19:38:50 +0100
-Subject: [PATCH] systemd-udevd.service.in: set MountFlags=shared
-
-This allows for udevd automounting of drives accessible to all.
----
- units/systemd-udevd.service.in | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/units/systemd-udevd.service.in b/units/systemd-udevd.service.in
-index 8b1dd0efc7..881930cdf4 100644
---- a/units/systemd-udevd.service.in
-+++ b/units/systemd-udevd.service.in
-@@ -26,7 +26,6 @@ ExecStart=@rootlibexecdir@/systemd-udevd
- ExecReload=@rootbindir@/udevadm control --reload --timeout 0
- KillMode=mixed
- TasksMax=infinity
--PrivateMounts=yes
- ProtectHostname=yes
- MemoryDenyWriteExecute=yes
- RestrictAddressFamilies=AF_UNIX AF_NETLINK AF_INET AF_INET6
---
-2.20.1
-
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 8ebb6cc..ea40849 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,5 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
-
-SRC_URI += " \
- file://0001-systemd-udevd.service.in-set-MountFlags-shared.patch \
-"
+# This allows for udevd automounting with mounts accessible to all.
+do_configure_prepend () {
+ sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
+} \ No newline at end of file