summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-11-21 18:58:43 +0100
committerStefan Agner <stefan.agner@toradex.com>2017-11-27 15:38:29 +0100
commite6641b0a6f93ebf752534b283d0dfb0c2c656ec2 (patch)
tree1b980cd38ec13ac1c5f72fc87dd37d467dd409f3
parent9cd2bc585283bce06825ea5538b424b9ec8deaf1 (diff)
linux-firmware: split out firmware for marvell sd8887Colibri-iMX6ULL_LXDE-Image_2.7b5-20171201Apalis-TK1_LXDE-Image_2.7b5-20171201
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-kernel/linux-firmware/linux-firmware_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
index 22ea955..12d95dc 100644
--- a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -1,3 +1,4 @@
+#----------------------------------------------------------
LICENSE_${PN}-rtl8188eu = "Firmware-rtlwifi_firmware"
PACKAGES_prepend = "\
@@ -7,3 +8,14 @@ FILES_${PN}-rtl8188eu = " \
/lib/firmware/rtlwifi/rtl8188eufw.bin \
"
RDEPENDS_${PN}-rtl8188eu += "${PN}-rtl-license"
+
+#----------------------------------------------------------
+LICENSE_${PN}-sd8887 = "Firmware-Marvell"
+
+PACKAGES_prepend = "\
+ ${PN}-sd8887 \
+ "
+FILES_${PN}-sd8887 = " \
+ /lib/firmware/mrvl/sd8887_uapsta.bin \
+"
+RDEPENDS_${PN}-sd8887 += "${PN}-marvell-license"