summaryrefslogtreecommitdiff
path: root/openembedded-layer
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-11-08 22:43:12 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-22 02:01:57 +0100
commit0b59fe5884ed8bbbd56de477650750229a729a8c (patch)
treeebb8bfad6be3ed0fcaa2a3132a9557a0b0b3b7ff /openembedded-layer
parent90879d57085f75203381f179927828136f7e0b7d (diff)
libvpx bbappend: follow version upgrade
The append is only needed for T20 as it does not have a neon unit. The other SoC compile fine without any change. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'openembedded-layer')
-rw-r--r--openembedded-layer/recipes-multimedia/webm/libvpx_%.bbappend10
1 files changed, 2 insertions, 8 deletions
diff --git a/openembedded-layer/recipes-multimedia/webm/libvpx_%.bbappend b/openembedded-layer/recipes-multimedia/webm/libvpx_%.bbappend
index b5ebaf0..7fd068d 100644
--- a/openembedded-layer/recipes-multimedia/webm/libvpx_%.bbappend
+++ b/openembedded-layer/recipes-multimedia/webm/libvpx_%.bbappend
@@ -1,10 +1,4 @@
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGE_ARCH_tegra2 = "${MACHINE_ARCH}"
#T20 does not have neon, but the armv7-linux-gcc assumes that the target has a neon unit
-VPXTARGET_armv7a_tegra2 = "armv6-linux-gcc"
-VPXTARGET_armv7a_qemuarm = "armv6-linux-gcc"
-
-CFLAGS_append_tegra3 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CFLAGS_append_mx6 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CFLAGS_append_mx7 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CONFIGUREOPTS += " --enable-runtime-cpu-detect "
+CONFIGUREOPTS_append_tegra2 = " --disable-runtime-cpu-detect --disable-neon --disable-neon-asm "