summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-12-17 11:01:34 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2014-12-17 11:16:09 +0100
commitf9597209fa87a9eea30d34448d993fdf82d4be61 (patch)
tree7c08c833c4c44808d3504653500a8beb912d2e28 /recipes-devtools
parent67c702cc06ec3add3b166af03f596b4adedda292 (diff)
e2fsck: don't check last mounttime on superblock
This avoids fsck execution. systemd-fsck[169]: arm: Superblock last write time (Tue Dec 16 15:46:16 2014, systemd-fsck[169]: now = Mon Nov 17 11:08:57 2014) is in the future. Depending on the system we might not have a sensible time. On top of that, during first boot we compare the fs creation time of the PC with the intial embedded time which very likely triggers the fsck.
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs/e2fsck.conf2
-rw-r--r--recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend9
2 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs/e2fsck.conf b/recipes-devtools/e2fsprogs/e2fsprogs/e2fsck.conf
new file mode 100644
index 0000000..2bce8a7
--- /dev/null
+++ b/recipes-devtools/e2fsprogs/e2fsprogs/e2fsck.conf
@@ -0,0 +1,2 @@
+[options]
+broken_system_clock = true
diff --git a/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend b/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
new file mode 100644
index 0000000..e767c2a
--- /dev/null
+++ b/recipes-devtools/e2fsprogs/e2fsprogs_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://e2fsck.conf"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+}
+
+FILES_e2fsprogs-e2fsck += "${sysconfdir}/e2fsck.conf"