summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-08-09 16:54:38 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:35:15 +0200
commit617e615193dd297f1cb5e4be29677c7e24803d97 (patch)
treed638b709c0da5a275a08d618c4339c34741ebe1a /recipes-support
parent71a8f744943ae4358ea414d743be8ae8cfceb9fa (diff)
meta-openembedded layer bbappends
Move the appends on recipe's which are not in an essential required layer into a target layer specific directory and add them only if said layer is active in build/conf/bblayers.conf. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libusbg/libusbg/g1.schema65
-rw-r--r--recipes-support/libusbg/libusbg/usbg.service17
-rw-r--r--recipes-support/libusbg/libusbg_git.bbappend25
3 files changed, 0 insertions, 107 deletions
diff --git a/recipes-support/libusbg/libusbg/g1.schema b/recipes-support/libusbg/libusbg/g1.schema
deleted file mode 100644
index ebe91b4..0000000
--- a/recipes-support/libusbg/libusbg/g1.schema
+++ /dev/null
@@ -1,65 +0,0 @@
-attrs :
-{
- bcdUSB = 0x0;
- bDeviceClass = 0x0;
- bDeviceSubClass = 0x0;
- bDeviceProtocol = 0x0;
- bMaxPacketSize0 = 0x40;
- idVendor = 0x1d6b;
- idProduct = 0x0104;
- bcdDevice = 0x400;
-};
-strings = (
- {
- lang = 0x409;
- manufacturer = "Toradex";
- product = "Unknown";
- serialnumber = "";
- } );
-functions :
-{
- acm_GS0 :
- {
- instance = "GS0";
- type = "acm";
- attrs :
- {
- port_num = 0;
- };
- };
- rndis_0 :
- {
- instance = "0";
- type = "rndis";
- attrs :
- {
- dev_addr = "00:14:2d:ff:ff:ff";
- host_addr = "00:14:2d:ff:ff:fe";
- qmult = 5;
- };
- };
-};
-configs = (
- {
- id = 1;
- name = "c";
- attrs :
- {
- bmAttributes = 0x80;
- bMaxPower = 0x2;
- };
- strings = (
- {
- lang = 0x409;
- configuration = "Conf 1";
- } );
- functions = (
- {
- name = "acm.GS0";
- function = "acm_GS0";
- },
- {
- name = "rndis.0";
- function = "rndis_0";
- } );
- } );
diff --git a/recipes-support/libusbg/libusbg/usbg.service b/recipes-support/libusbg/libusbg/usbg.service
deleted file mode 100644
index 19863d0..0000000
--- a/recipes-support/libusbg/libusbg/usbg.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=Load default USB gadget schema g1.schema
-ConditionPathExists=/etc/usbg/g1.schema
-Before=systemd-networkd.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/gadget-import g1 /etc/usbg/g1.schema
-ExecStartPost=/bin/sh -c '/bin/cat /proc/device-tree/model > \
- /sys/kernel/config/usb_gadget/g1/strings/0x409/product'
-ExecStartPost=/bin/sh -c '/bin/cat /proc/device-tree/serial-number > \
- /sys/kernel/config/usb_gadget/g1/strings/0x409/serialnumber'
-ExecStartPost=/bin/sh -c '/bin/echo `ls /sys/class/udc/` > \
- /sys/kernel/config/usb_gadget/g1/UDC'
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-support/libusbg/libusbg_git.bbappend b/recipes-support/libusbg/libusbg_git.bbappend
deleted file mode 100644
index ceb009d..0000000
--- a/recipes-support/libusbg/libusbg_git.bbappend
+++ /dev/null
@@ -1,25 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/libusbg:"
-
-PV = "0.1.0-git"
-
-SRCREV = "93631e618436989ebd7e9df2c997c175feb14bda"
-SRC_URI = "git://github.com/kopasiak/libusbg.git \
- file://usbg.service \
- file://g1.schema \
-"
-
-DEPENDS = "libconfig"
-
-inherit autotools pkgconfig systemd
-
-do_install_append () {
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/usbg.service ${D}${systemd_unitdir}/system
-
- install -d ${D}${sysconfdir}/usbg/
- install -m 0644 ${WORKDIR}/g1.schema ${D}${sysconfdir}/usbg/g1.schema
-}
-
-NATIVE_SYSTEMD_SUPPORT = "1"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "usbg.service"