summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend2
-rw-r--r--recipes-kernel/linux-firmware/linux-firmware_%.bbappend6
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/aarch64/defconfig1
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/defconfig1
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v6_v7.config3
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v8.config3
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb4
7 files changed, 14 insertions, 6 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 6baccf4..bbccdd9 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://weston.sh"
PACKAGECONFIG:append:upstream:tdx = " no-idle-timeout"
-PACKAGECONFIG:append:am62x = " no-idle-timeout"
+PACKAGECONFIG:append:k3 = " no-idle-timeout"
PACKAGECONFIG:append:upstream:colibri-imx6ull = " use-pixman"
PACKAGECONFIG:append:upstream:colibri-imx6ull-emmc = " use-pixman"
PACKAGECONFIG:append:upstream:colibri-imx7 = " use-pixman"
diff --git a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
index 68251c2..6bfd97e 100644
--- a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -1,10 +1,10 @@
IMX_FIRMWARE_SRC ?= "git://github.com/NXP/imx-firmware.git;protocol=https"
-SRCBRANCH_imx-firmware = "lf-6.1.55_2.2.0"
+SRCBRANCH_imx-firmware = "lf-6.6.3_1.0.0"
SRC_URI += " \
${IMX_FIRMWARE_SRC};branch=${SRCBRANCH_imx-firmware};destsuffix=${S}/imx-firmware;name=imx-firmware \
"
-SRCREV_imx-firmware = "7be5a936ce8677962dd7b41c6c9f41dd14350bec"
+SRCREV_imx-firmware = "2afa15e77f0b58eade42b4f59c9215339efcca66"
SRCREV_FORMAT = "default_imx-firmware"
@@ -35,7 +35,7 @@ LICENSE += " \
& firmware-imx \
"
LIC_FILES_CHKSUM += " \
- file://imx-firmware/LICENSE.txt;md5=2827219e81f28aba7c6a569f7c437fa7 \
+ file://imx-firmware/LICENSE.txt;md5=44a8052c384584ba09077e85a3d1654f \
"
NO_GENERIC_LICENSE[firmware-imx] = "imx-firmware/LICENSE.txt"
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/aarch64/defconfig b/recipes-kernel/linux/linux-toradex-mainline-git/aarch64/defconfig
index f824824..ac28c5e 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/aarch64/defconfig
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/aarch64/defconfig
@@ -842,6 +842,7 @@ CONFIG_SND_SOC_LPASS_VA_MACRO=m
CONFIG_SND_SIMPLE_CARD=m
CONFIG_SND_AUDIO_GRAPH_CARD=m
CONFIG_SND_AUDIO_GRAPH_CARD2=m
+CONFIG_UHID=m
CONFIG_HID_MULTITOUCH=m
CONFIG_I2C_HID_ACPI=m
CONFIG_I2C_HID_OF=m
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/defconfig b/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
index 303a479..b317c79 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
@@ -261,6 +261,7 @@ CONFIG_SND_SOC_FSL_ASOC_CARD=y
CONFIG_SND_SOC_AC97_CODEC=y
CONFIG_SND_SOC_NAU8822=m
CONFIG_SND_SIMPLE_CARD=y
+CONFIG_UHID=m
CONFIG_HID_MULTITOUCH=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_CONN_GPIO=y
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v6_v7.config b/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v6_v7.config
index cec4fa5..ecbd237 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v6_v7.config
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v6_v7.config
@@ -44,6 +44,9 @@ CONFIG_RT_GROUP_SCHED=n
# SPI test and debugging
CONFIG_SPI_SPIDEV=y
+# Support Bluetooth HID devices
+CONFIG_UHID=m
+
# Support HID devices
# This suppresses also the warning "hid-generic: device has no listeners, quitting"
CONFIG_USB_HIDDEV=y
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v8.config b/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v8.config
index 549f503..1ac29c0 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v8.config
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/toradex_imx_v8.config
@@ -53,6 +53,9 @@ CONFIG_RPMSG_TTY=m
CONFIG_SAMPLES=y
CONFIG_SAMPLE_RPMSG_CLIENT=m
+# Support Bluetooth HID devices
+CONFIG_UHID=m
+
# Disable unnecessary TV stuff
CONFIG_MEDIA_ANALOG_TV_SUPPORT=n
CONFIG_MEDIA_DIGITAL_TV_SUPPORT=n
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index 5ea1158..a58cc27 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -55,10 +55,10 @@ SRC_URI:append = " \
file://0002-arm-dts-nxp-imx-Add-support-for-Apalis-Evaluation-Bo.patch \
"
-LINUX_VERSION ?= "6.1.84"
+LINUX_VERSION ?= "6.1.89"
KBRANCH = "linux-6.1.y"
KERNEL_VERSION_SANITY_SKIP = "1"
-SRCREV_machine = "347385861c50adc8d4801d4b899eded38a2f04cd"
+SRCREV_machine = "dcbc050cb0d304c3427d6583384eebcaf0e3caee"
SRCREV_machine:use-head-next = "${AUTOREV}"
S = "${WORKDIR}/git"