summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-toradex_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_%.bbappend b/recipes-kernel/linux/linux-toradex_%.bbappend
new file mode 100644
index 0000000..04a2451
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_%.bbappend
@@ -0,0 +1,15 @@
+do_shared_workdir_append () {
+ if [ -f include/config/auto.conf ]; then
+ mkdir -p $kerneldir/include/config/
+ cp -f include/config/auto.conf $kerneldir/include/config/
+ fi
+
+ ln -sf ${STAGING_KERNEL_DIR} ${kerneldir}/source
+
+ if [ ! -f $kerneldir/Makefile ]; then
+ VERSION=$(grep "^VERSION =" Makefile | sed s/.*=\ *//)
+ PATCHLEVEL=$(grep "^PATCHLEVEL =" Makefile | sed s/.*=\ *//)
+ bash ${S}/scripts/mkmakefile $(pwd) $kerneldir $VERSION $PATCHLEVEL
+ fi
+}
+