summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 474ec66..f7a5ae9 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -12,24 +12,16 @@ SRC_URI = " \
KERNEL_BOOTCMD ??= "bootz"
KERNEL_BOOTCMD_aarch64 ?= "booti"
-S = "${WORKDIR}"
+inherit deploy nopackages
-inherit deploy
-
-do_compile() {
+do_deploy() {
sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
"${WORKDIR}/boot.cmd.in" > boot.cmd
- mkimage -T script -C none -n "Distro boot script" -d "${WORKDIR}/boot.cmd" boot.scr
-}
+ mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr
-do_deploy() {
- install -d ${DEPLOYDIR}
install -m 0644 boot.scr ${DEPLOYDIR}
}
addtask deploy after do_install before do_build
-do_install[noexec] = "1"
-do_populate_sysroot[noexec] = "1"
-
PACKAGE_ARCH = "${MACHINE_ARCH}"