summaryrefslogtreecommitdiff
path: root/recipes-bsp/gpio-export/gpio-export_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/gpio-export/gpio-export_1.0.bb')
-rw-r--r--recipes-bsp/gpio-export/gpio-export_1.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/gpio-export/gpio-export_1.0.bb b/recipes-bsp/gpio-export/gpio-export_1.0.bb
new file mode 100644
index 0000000..02d0fd7
--- /dev/null
+++ b/recipes-bsp/gpio-export/gpio-export_1.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Scripts and systemd service file to export unused GPIO to Userspace"
+LICENSE = "Public Domain"
+PR = "r2"
+
+inherit systemd
+
+SRC_URI = " \
+ file://gpio-export.sh \
+ file://gpio-export.service \
+ file://COPYING \
+"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
+
+do_compile () {
+}
+
+do_install () {
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/*.sh ${D}/${bindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/gpio-export.service ${D}${systemd_unitdir}/system
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "gpio-export.service"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}" \ No newline at end of file