summaryrefslogtreecommitdiff
path: root/recipes-core/usb-rndis/usb-rndis-systemd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/usb-rndis/usb-rndis-systemd.bb')
-rw-r--r--recipes-core/usb-rndis/usb-rndis-systemd.bb48
1 files changed, 20 insertions, 28 deletions
diff --git a/recipes-core/usb-rndis/usb-rndis-systemd.bb b/recipes-core/usb-rndis/usb-rndis-systemd.bb
index d229123..1ea8090 100644
--- a/recipes-core/usb-rndis/usb-rndis-systemd.bb
+++ b/recipes-core/usb-rndis/usb-rndis-systemd.bb
@@ -2,54 +2,46 @@ SECTION = "network"
SUMMARY = "RNDIS usb client configuration and startup"
RDEPENDS_${PN} = ""
# The license is meant for this recipe and the files it installs.
-# RNDIS is part of the kernel, udhcpd is part of busybox
+# RNDIS is part of the kernel, systemd-networkd is part of systemd
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
PR = "r1"
# Tegra Kernels:
-# The kernel provides with CONFIG_USB_G_ANDROID a composite gadget driver among other with RNDIS functionality.
-# Others:
-# The kernel provides with CONFIG_USB_ETH_RNDIS a USB gadget driver which provides RNDIS functionality.
-
-# This package contains systemd files to configure RNDIS at startup, configures a fix IP localy and provides a dhcp server on the new interface.
-# Local IP is 192.168.11.2, remote IP is 192.168.11.1
+# The kernel provides with CONFIG_USB_G_ANDROID a composite gadget driver
+# among other with RNDIS functionality.
+# i.MX6 Kernels:
+# The kernel provides with CONFIG_USB_ETH_RNDIS an USB gadget driver which
+# provides RNDIS functionality.
+# Vybrid Kernels:
+# The kernel provides with CONFIG_USB_CONFIGFS_RNDIS an USB gadget driver
+# which provides RNDIS functionality. RNDIS needs to be configured and
+# enabled through configfs, which is done by libusbg (usbg.service)
+
+# This package contains systemd files to configure RNDIS at startup (Tegra
+# and i.MX6), configures a fix IP locally and provides a DHCP server using
+# systemd-networkd
+# Local IP is 192.168.11.1, remote IP is 192.168.11.2
inherit allarch systemd
-SRC_URI_COMMON = " \
+SRC_URI = " \
file://start-rndis.sh \
file://usb-rndis.service \
- file://udhcpd-usb-rndis.conf \
-"
-
-SRC_URI = " \
- ${SRC_URI_COMMON} \
-"
-
-SRC_URI_tegra = " \
- ${SRC_URI_COMMON} \
- file://usb-rndis.rules \
- file://usb-rndis-udhcpd.service \
"
do_install() {
- install -d ${D}/${sysconfdir} ${D}/${bindir}
+ install -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/start-rndis.sh ${D}/${bindir}/
- install -m 0644 ${WORKDIR}/udhcpd-usb-rndis.conf ${D}/${sysconfdir}/
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/usb-rndis.service ${D}${systemd_unitdir}/system
}
-do_install_append_tegra() {
- install -d ${D}/${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/usb-rndis.rules ${D}/${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/usb-rndis-udhcpd.service ${D}${systemd_unitdir}/system
-}
-
-FILES_${PN} += "${systemd_unitdir}/system"
+FILES_${PN} += " \
+ ${systemd_unitdir}/system \
+"
NATIVE_SYSTEMD_SUPPORT = "1"
SYSTEMD_PACKAGES = "${PN}"