summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-05-26 13:25:57 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-05-19 16:08:49 +0200
commitda1129748dbea46522269eb87a99502f12ed20e8 (patch)
tree0d0f4c81c5aff9fa20ec08cff5d99dfdb5f7795e
parent014344d116f7c17c10be35d0d2a66a0038df6c75 (diff)
systemd: rework packageconfig for meson build
The upstream systemd recipe now uses meson to build systemd. Follow the changed config syntax. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 6632d136cada3ae3b4cecdf29c611101778da5d4)
-rw-r--r--recipes-core/systemd/systemd_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index a31646f..afbc6f8 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -4,7 +4,7 @@ SRC_URI += "file://rndis.network"
PACKAGECONFIG_append = " networkd"
-PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
+PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
do_install_append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...