summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-10-17 12:27:29 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-02 19:04:46 +0200
commit4ed69a5eda94110fcb301940751d09bcdfe76762 (patch)
treec528d8a0de2e5724c9dc1eea29cb474c24114add
parent10f7ba8aed6ffb2e85169ac5efab741e62bd0ff5 (diff)
clpeak: add recipe
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 2bba608252c7c09447e94bbacf8b1310113b12ff)
-rw-r--r--recipes-benchmark/clpeak/clpeak/0001-CMakeLists-add-install-rule.patch22
-rw-r--r--recipes-benchmark/clpeak/clpeak_git.bb15
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-benchmark/clpeak/clpeak/0001-CMakeLists-add-install-rule.patch b/recipes-benchmark/clpeak/clpeak/0001-CMakeLists-add-install-rule.patch
new file mode 100644
index 0000000..68f0762
--- /dev/null
+++ b/recipes-benchmark/clpeak/clpeak/0001-CMakeLists-add-install-rule.patch
@@ -0,0 +1,22 @@
+From 72a7027518afa64c06b3108b3b52607eb230f9d8 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Wed, 17 Oct 2018 09:31:08 +0000
+Subject: [PATCH] CMakeLists: add install rule
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7fb29b5..77f37a2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,3 +112,4 @@ add_executable(clpeak ${SOURCE_FILES})
+
+ target_link_libraries(clpeak ${OPENCL_LIBS})
+
++install(TARGETS clpeak RUNTIME DESTINATION bin)
+--
+2.13.6
+
diff --git a/recipes-benchmark/clpeak/clpeak_git.bb b/recipes-benchmark/clpeak/clpeak_git.bb
new file mode 100644
index 0000000..fa64b49
--- /dev/null
+++ b/recipes-benchmark/clpeak/clpeak_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A tool which profiles OpenCL devices to find their peak capacities"
+HOMEPAGE = "https://github.com/krrishnarraj/clpeak"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=911690f51af322440237a253d695d19f"
+DEPENDS = "virtual/opencl-icd"
+
+SRC_URI = " \
+ git://github.com/krrishnarraj/clpeak.git;protocol=https \
+ file://0001-CMakeLists-add-install-rule.patch \
+"
+
+SRCREV = "8edab23fbc867adbada21378d65774c670c2aaf9"
+S = "${WORKDIR}/git"
+
+inherit cmake