summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBhuvanchandra DV <bhuvanchandra.dv@toradex.com>2017-04-24 10:51:56 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-06-30 17:43:40 +0200
commit4299283326f57381614d4e912308cf51bb8a6e2e (patch)
treed63360168f0a37b0b6da719a8be739199d7809f6
parent0d5f1bc01c6e8793490cf39e7f957bfe34ed1750 (diff)
systemd: Add a acl packageconfig
We found that having ACL enabled in systemd on a ubifs adversely affects power cut resilience. Currently systemd is unconditionally enabled in a systemd build. Add a acl packageconfig option, but do not enable it. Signed-off-by: Bhuvanchandra DV <bhuvanchandra.dv@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-core/systemd/systemd_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 8130a38..a31646f 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -4,6 +4,8 @@ SRC_URI += "file://rndis.network"
PACKAGECONFIG_append = " networkd"
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
+
do_install_append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
install -d ${D}${prefix}/lib/systemd/network/