summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-11-18 14:44:28 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-22 15:52:09 +0100
commit3cf47c85e24314f8705ffbe6fbd432c18ada0301 (patch)
treefacafa40b2ddc1fd63fdad0d13f1815910f75024
parent39beb3b636b63e5300ab0bc58e85d9f720418b12 (diff)
lxde-common: add plugins to panel configuration
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-lxde/lxde-common/lxde-common/0001-panel.in-add-to-panel-configuration.patch76
-rw-r--r--recipes-lxde/lxde-common/lxde-common/panel-buttons.patch24
-rw-r--r--recipes-lxde/lxde-common/lxde-common_%.bbappend2
3 files changed, 77 insertions, 25 deletions
diff --git a/recipes-lxde/lxde-common/lxde-common/0001-panel.in-add-to-panel-configuration.patch b/recipes-lxde/lxde-common/lxde-common/0001-panel.in-add-to-panel-configuration.patch
new file mode 100644
index 0000000..f93f9ee
--- /dev/null
+++ b/recipes-lxde/lxde-common/lxde-common/0001-panel.in-add-to-panel-configuration.patch
@@ -0,0 +1,76 @@
+From acbd5b137a53d8d5c947aab4d84b72adf71be2d4 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Sat, 18 Nov 2017 14:33:59 +0100
+Subject: [PATCH 1/2] panel.in: add to panel configuration
+
+fix the firefox.desktop file name
+add lxterminal
+add network stat plugin
+add temperature plugin
+add logout
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ lxpanel/panel.in | 25 +++++++++++++++++++++----
+ 1 file changed, 21 insertions(+), 4 deletions(-)
+
+diff --git a/lxpanel/panel.in b/lxpanel/panel.in
+index 865c432..8d51814 100644
+--- a/lxpanel/panel.in
++++ b/lxpanel/panel.in
+@@ -55,7 +55,10 @@ Plugin {
+ id=pcmanfm.desktop
+ }
+ Button {
+- id=firefox.desktop
++ id=mozilla-firefox.desktop
++ }
++ Button {
++ id=lxterminal.desktop
+ }
+ }
+ }
+@@ -112,6 +115,10 @@ Plugin {
+ }
+
+ Plugin {
++ type = netstat
++}
++
++Plugin {
+ type = cpu
+ }
+
+@@ -129,6 +136,19 @@ Plugin {
+ }
+
+ Plugin {
++ type = thermal
++ Config {
++ NormalColor=#00ff00
++ Warning1Color=#fff000
++ Warning2Color=#ff0000
++ AutomaticLevels=1
++ Warning1Temp=75
++ Warning2Temp=80
++ AutomaticSensor=1
++ }
++}
++
++Plugin {
+ type = dclock
+ Config {
+ ClockFmt=%R
+@@ -141,9 +161,6 @@ Plugin {
+ type = launchbar
+ Config {
+ Button {
+- id=lxde-screenlock.desktop
+- }
+- Button {
+ id=lxde-logout.desktop
+ }
+ }
+--
+2.13.6
+
diff --git a/recipes-lxde/lxde-common/lxde-common/panel-buttons.patch b/recipes-lxde/lxde-common/lxde-common/panel-buttons.patch
deleted file mode 100644
index 1a20937..0000000
--- a/recipes-lxde/lxde-common/lxde-common/panel-buttons.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- lxde-common-0.99.0/lxpanel/panel.in~ 2014-10-23 16:08:00.000000000 +0200
-+++ lxde-common-0.99.0/lxpanel/panel.in 2014-12-29 22:16:04.310587839 +0100
-@@ -53,7 +53,10 @@
- id=pcmanfm.desktop
- }
- Button {
-- id=firefox.desktop
-+ id=mozilla-firefox.desktop
-+ }
-+ Button {
-+ id=lxterminal.desktop
- }
- }
- }
-@@ -134,9 +137,6 @@
- type = launchbar
- Config {
- Button {
-- id=lxde-screenlock.desktop
-- }
-- Button {
- id=lxde-logout.desktop
- }
- }
diff --git a/recipes-lxde/lxde-common/lxde-common_%.bbappend b/recipes-lxde/lxde-common/lxde-common_%.bbappend
index b45c7dd..b0eb1c3 100644
--- a/recipes-lxde/lxde-common/lxde-common_%.bbappend
+++ b/recipes-lxde/lxde-common/lxde-common_%.bbappend
@@ -15,7 +15,7 @@ SRC_URI += " \
file://wallpaper.patch \
file://desktop.conf \
file://defaults.list \
- file://panel-buttons.patch \
+ file://0001-panel.in-add-to-panel-configuration.patch \
"
# for apalis-imx6/colibri-imx6, we decide on the target during postinst