summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-01-01 16:08:46 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-03-22 09:19:26 +0100
commita421edda89135eb71b94135d18942a2f4635d9c9 (patch)
treec92951fd25979f34a2d5fc69f4a6c81558ceb40a
parent30cff779fcc76203f0694cf517b7d96d1f7f3603 (diff)
lxqt-panel: add config with more widgets
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel/panel.conf118
-rw-r--r--meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel_%.bbappend9
2 files changed, 127 insertions, 0 deletions
diff --git a/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel/panel.conf b/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel/panel.conf
new file mode 100644
index 0000000..4b98b39
--- /dev/null
+++ b/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel/panel.conf
@@ -0,0 +1,118 @@
+[General]
+__userfile__=true
+
+[desktopswitch]
+alignment=Left
+type=desktopswitch
+
+[mainmenu]
+alignment=Left
+type=mainmenu
+
+[mount]
+alignment=Right
+type=mount
+
+[panel1]
+alignment=-1
+animation-duration=0
+background-color=@Variant(\0\0\0\x43\0\xff\xff\0\0\0\0\0\0\0\0)
+background-image=
+desktop=0
+font-color=@Variant(\0\0\0\x43\0\xff\xff\0\0\0\0\0\0\0\0)
+hidable=false
+iconSize=22
+lineCount=1
+lockPanel=false
+opacity=100
+panelSize=32
+plugins=mainmenu, desktopswitch, quicklaunch, taskbar, tray, statusnotifier, mount, volume, clock, showdesktop, sensors, sysstat, worldclock2
+position=Bottom
+reserve-space=true
+show-delay=0
+width=100
+width-percent=true
+
+[quicklaunch]
+alignment=Left
+apps\1\desktop=/usr/share/applications/pcmanfm-qt.desktop
+apps\2\desktop=/usr/share/applications/qterminal.desktop
+apps\size=2
+type=quicklaunch
+
+[sensors]
+alignment=Right
+chips\imx_thermal_zone-virtual-0\temp1\color=#628cb2
+chips\imx_thermal_zone-virtual-0\temp1\enabled=true
+tempBarWidth=8
+type=sensors
+updateInterval=1
+useFahrenheitScale=false
+warningAboutHighTemperature=true
+
+[showdesktop]
+alignment=Right
+type=showdesktop
+
+[statusnotifier]
+alignment=Right
+type=statusnotifier
+
+[sysstat]
+alignment=Right
+cpu\frequencyColour=#808080
+cpu\niceColour=#008000
+cpu\otherColour=#808000
+cpu\systemColour=#800000
+cpu\useFrequency=false
+cpu\userColour=#00ff7f
+data\source=cpu
+data\type=CPU
+graph\minimalSize=30
+graph\updateInterval=1
+graph\useThemeColours=false
+grid\colour=#808080
+grid\lines=1
+mem\appsColour=#000080
+mem\buffersColour=#008000
+mem\cachedColour=#808000
+mem\swapColour=#800000
+net\logarithmicScale=true
+net\logarithmicScaleSteps=4
+net\maximumSpeed=1 MB/s
+net\receivedColour=#000080
+net\transmittedColour=#808000
+title\colour=#000000
+title\label=
+type=sysstat
+
+[taskbar]
+alignment=Left
+autoRotate=true
+buttonHeight=100
+buttonStyle=IconText
+buttonWidth=200
+closeOnMiddleClick=true
+cycleOnWheelScroll=true
+groupingEnabled=true
+iconByClass=false
+raiseOnCurrentDesktop=false
+showDesktopNum=0
+showGroupOnHover=true
+showOnlyCurrentScreenTasks=false
+showOnlyMinimizedTasks=false
+showOnlyOneDesktopTasks=false
+type=taskbar
+
+[tray]
+alignment=Right
+type=tray
+
+[volume]
+alignment=Right
+audioEngine=Alsa
+type=volume
+
+[worldclock2]
+alignment=Right
+type=worldclock
diff --git a/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel_%.bbappend b/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel_%.bbappend
new file mode 100644
index 0000000..52b09c4
--- /dev/null
+++ b/meta-qt5-extra/recipes-lxqt/lxqt-panel/lxqt-panel_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/lxqt-panel:"
+
+# add some widgets, add some applications to quicklaunch by injecting
+# panel.conf configured on the target
+
+SRC_URI += "file://panel.conf"
+do_configure_prepend () {
+ cp ${WORKDIR}/panel.conf ${S}/panel/resources/
+}