summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:09:54 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-06-19 09:09:54 +0200
commit362c0d8250ae1b8d7b2afce5bc4b27075fe82c68 (patch)
treef9fd52c57fb7f7592ff358eed1fe59ec9b3d113c
parentb3f0841ade3dc1cbd1b7dd825439cb03a02629d2 (diff)
Update to new NV binary packages L4T R15
Removed nvrm_deamon and corresponding init.d script Kernel from git.toradex.int
-rw-r--r--recipes-kernel/linux/linux-colibri-t20_git.bb15
-rw-r--r--recipes-kernel/linux/linux-colibri-t20_git.bb~36
-rwxr-xr-xrecipes/gpioconfig/files/GPIOConfig.desktop~11
-rwxr-xr-xrecipes/gpioconfig/files/Makefile31
-rw-r--r--recipes/gpioconfig/gpioconfig.bb~44
-rw-r--r--recipes/images/console-trdx-image.bb~44
-rw-r--r--recipes/images/lx.inc~39
-rw-r--r--recipes/images/trdx-extra.inc~55
-rw-r--r--recipes/trdx-config/angstrom-feed-configs.bb~89
-rw-r--r--recipes/trdx-config/trdx-config.bb~30
10 files changed, 11 insertions, 383 deletions
diff --git a/recipes-kernel/linux/linux-colibri-t20_git.bb b/recipes-kernel/linux/linux-colibri-t20_git.bb
index be91e90..b081ab8 100644
--- a/recipes-kernel/linux/linux-colibri-t20_git.bb
+++ b/recipes-kernel/linux/linux-colibri-t20_git.bb
@@ -1,15 +1,18 @@
inherit kernel
require recipes-kernel/linux/linux.inc
-LINUX_VERSION ?= "2.6.36.2"
+LINUX_VERSION ?= "3.1.10"
-SRCREV = "99003b6bd73fd8ce4f2bd63a1c7b63f8c3d0cf68"
+SRCREV = "37440f3ed07a6f588b05b8f98d0b3025c1949371"
-PV = "2.6.36.2+gitr${SRCREV}"
+PV = "${LINUX_VERSION}+gitr${SRCREV}"
PR = "V1.1b1"
S = "${WORKDIR}/git"
+#SRC_URI = "\
+# git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-linux-kernel.git;protocol=git;branch=master \
+# file://bcm4329_warning.patch "
SRC_URI = "\
- git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-linux-kernel.git;protocol=git;branch=master \
+ git://git.toradex.com/linux-colibri.git;protocol=git;branch=colibri \
file://bcm4329_warning.patch "
#SVN_REV = 190
@@ -35,5 +38,9 @@ do_configure_prepend_colibri-t20() {
echo "KBUILD_CFLAGS += -mno-unaligned-access" >> ${S}/Makefile
}
+do_compile_kernelmodules_colibri-t20() {
+ :
+}
+
#require recipes-kernel/linux/linux-tools.inc
diff --git a/recipes-kernel/linux/linux-colibri-t20_git.bb~ b/recipes-kernel/linux/linux-colibri-t20_git.bb~
deleted file mode 100644
index 233f087..0000000
--- a/recipes-kernel/linux/linux-colibri-t20_git.bb~
+++ /dev/null
@@ -1,36 +0,0 @@
-inherit kernel
-require recipes-kernel/linux/linux.inc
-
-LINUX_VERSION ?= "2.6.36.2"
-
-SRCREV = "99003b6bd73fd8ce4f2bd63a1c7b63f8c3d0cf68"
-
-PV = "2.6.36.2+gitr${SRCREV}"
-PR = "V1.0b6"
-S = "${WORKDIR}/git"
-SRC_URI = "\
- git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-linux-kernel.git;protocol=git;branch=master \
- file://bcm4329_warning.patch "
-
-#SVN_REV = 190
-#PV = "2.6.36.2"
-#PR = "${SVN_REV}"
-#S = "${WORKDIR}/kernel"
-#SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=kernel;rev=${SVN_REV};proto=http \
-# file://bcm4329_warning.patch "
-
-COMPATIBLE_MACHINE = "colibri-t20"
-
-CMDLINE="mem=148M@0M fbmem=12M@148M nvmem=96M@160M vmalloc=248M video=tegrafb root=/dev/nfs ip=:::::eth0:on rw netdevwait mtdparts=tegra_nand:1018368K@28160K(userspace) console=ttyS0,115200n8 usb_high_speed=0"
-
-do_configure_prepend_colibri-t20() {
- #use the defconfig provided in the kernel source tree
- install -m 0644 ${S}/arch/arm/configs/colibri_t20_defconfig ${WORKDIR}/defconfig
-
- #compile with -O2, 4.5. compiler seems to fail with -Os
- sed -i -e /CONFIG_CC_OPTIMIZE_FOR_SIZE/d ${WORKDIR}/defconfig
- echo "CONFIG_CC_OPTIMIZE_FOR_SIZE=n" >> ${WORKDIR}/defconfig
-}
-
-#require recipes-kernel/linux/linux-tools.inc
-
diff --git a/recipes/gpioconfig/files/GPIOConfig.desktop~ b/recipes/gpioconfig/files/GPIOConfig.desktop~
deleted file mode 100755
index 4a0e9ac..0000000
--- a/recipes/gpioconfig/files/GPIOConfig.desktop~
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/env xdg-open
-
-[Desktop Entry]
-Version=1.0
-Type=Application
-Terminal=false
-Icon[C]=gnome-panel-launcher
-Exec=/usr/bin/GPIOConfig
-Name[C]=GPIOConfig
-Name=GPIOConfig
-Icon=/usr/share/pixmaps/GPIOConfig.png
diff --git a/recipes/gpioconfig/files/Makefile b/recipes/gpioconfig/files/Makefile
deleted file mode 100755
index 2b0143d..0000000
--- a/recipes/gpioconfig/files/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-CROSS_COMPILE ?= /vibrante/toolchains/tegra2-4.4.1-nv/bin/arm-none-linux-gnueabi-
-CC ?= $(CROSS_COMPILE)gcc
-STRIP ?= $(CROSS_COMPILE)strip
-
-SYSROOT_DIR=/srv/nfs/rootfs-include-lib-gtk
-prefix = ""
-bindir = $(prefix)/usr/bin
-
-CFLAGS ?= -Wall -g -O2 `pkg-config --cflags gtk+-2.0`
-
-#DRV = gpio_usr_drv
-
-PROG = GPIOConfig
-
-OBJS = gpio_gtk.o custom-list.o gpio_usr_drv.o
-
-all: $(OBJS)
-# $(CC) -o $(DRV) $(DRV).c
- $(CC) -o $(PROG) $(OBJS) $(LDFLAGS) `pkg-config --cflags gtk+-2.0` `pkg-config --libs gtk+-2.0` -L $(SYSROOT_DIR)/usr/lib -Wl,--allow-shlib-undefined
- $(STRIP) $(PROG)
-
-%o: %c
- $(CC) $(CFLAGS) $(CPPFLAGS) `pkg-config --cflags gtk+-2.0` -c $<
-
-clean:
- rm -f $(DRV) $(PROG) $(OBJS) *.o~ *.h~ 2>/dev/null
-
-install:
- install -d $(bindir)
- install $(PROG) $(bindir)
-
diff --git a/recipes/gpioconfig/gpioconfig.bb~ b/recipes/gpioconfig/gpioconfig.bb~
deleted file mode 100644
index e5e6435..0000000
--- a/recipes/gpioconfig/gpioconfig.bb~
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "GPIOConfig tool for Colibri T20"
-SECTION = "base"
-LICENSE = "propriatry"
-PR = "r3"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS = "gtk+"
-RDEPENDS = "gtk+"
-
-S = "${WORKDIR}/target-utils/GPIOConfig"
-
-SVN_REV = "230"
-SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=target-utils/GPIOConfig;rev=${SVN_REV};proto=http"
-#SRC_URI += "file://Makefile"
-SRC_URI += "file://GPIOConfig.desktop"
-SRC_URI += "file://GPIOConfig.png"
-
-PACKAGES = "${PN}"
-
-# just don't do any configuring
-do_configure() {
-}
-
-do_install() {
- install -d ${D}/${bindir}
- install -d ${D}/${datadir}/applications
- install -d ${D}/${datadir}/pixmaps
- install ${S}/GPIOConfig ${D}/${bindir}
- install ${WORKDIR}/GPIOConfig.desktop ${D}/${datadir}/applications
- install ${WORKDIR}/GPIOConfig.png ${D}/${datadir}/pixmaps/GPIOConfig.png
-}
-
-pkg_postinst_${PN}() {
- mkdir -p ${base_prefix}/home/root/Desktop
- cp ${datadir}/applications/GPIOConfig.desktop ${base_prefix}/home/root/Desktop/
-}
-
-pkg_postremove_${PN}() {
- rm -f ${base_prefix}/home/Desktop/GPIOConfig.desktop
-}
-
-
-
diff --git a/recipes/images/console-trdx-image.bb~ b/recipes/images/console-trdx-image.bb~
deleted file mode 100644
index 8d56094..0000000
--- a/recipes/images/console-trdx-image.bb~
+++ /dev/null
@@ -1,44 +0,0 @@
-#Angstrom image
-DESCRIPTION = "Image booting to a console"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-#create the file /etc/timestamp
-IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
-
-#IMAGE_LINGUAS = ""
-#IMAGE_LINGUAS = "en-us"
-#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
-
-ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
-
-DISTRO_UPDATE_ALTERNATIVES ??= ""
-ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
-CONMANPKGS_libc-uclibc = ""
-
-
-IMAGE_INSTALL += " \
- angstrom-task-boot \
- task-basic \
- ${CONMANPKGS} \
- ${ROOTFS_PKGMANAGE_PKGS} \
- task-base-extended \
- ${ANGSTROM_EXTRA_INSTALL} \
- ${SPLASH} \
- ${ZZAPSPLASH} \
-"
-
-include trdx-extra.inc
-
-IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
-IMAGE_INITSCRIPTS = "initscripts"
-IMAGE_LOGIN_MANAGER = "tinylogin shadow"
-
-export IMAGE_BASENAME = "console-trdx-image"
-
-inherit image
diff --git a/recipes/images/lx.inc~ b/recipes/images/lx.inc~
deleted file mode 100644
index 1d9cfad..0000000
--- a/recipes/images/lx.inc~
+++ /dev/null
@@ -1,39 +0,0 @@
-IMAGE_INSTALL += " \
- task-lxde-extended \
- \
- xinput-calibrator \
- \
- lxde-common \
- openbox \
- openbox-theme-clearlooks \
- openbox-theme-onyx \
- lxde-icon-theme \
- hicolor-icon-theme \
- lxdm \
- lxsession \
- lxmenu-data \
- menu-cache \
- lxappearance \
- obconf \
- lxpanel \
- \
- lxtask \
- lxpolkit \
- lxsession-edit \
- \
- lxshortcut \
- lxlauncher \
- pcmanfm \
- leafpad \
- gpicview \
- lxterminal \
- lxinput \
-"
-# angstrom-task-lxde \
-# task-lxde-xserver \
-# task-lxde-xserver-base \
-# xkbd \
-# xcursor-themes \
-# lxappearance-obconf \
-# lxrandr \
-# policykit-gnome \
diff --git a/recipes/images/trdx-extra.inc~ b/recipes/images/trdx-extra.inc~
deleted file mode 100644
index df14875..0000000
--- a/recipes/images/trdx-extra.inc~
+++ /dev/null
@@ -1,55 +0,0 @@
-#additional packages to include in our Toradex images
-
-#the following builds cross gdb
-DEPENDS += "gdb-cross"
-
-#the gdb recipe provides gdbserver
-DEPENDS += "gdb"
-
-IMAGE_INSTALL_MACHINE_colibri-t20 += " \
- trdx-odm \
-"
-IMAGE_INSTALL_MACHINE += " \
-"
-
-IMAGE-INSTALL += " \
- alsa-utils \
- alsa-utils-aplay \
- alsa-utils-amixer \
- \
- \
- aspell \
- consolekit \
- sqlite3 \
- \
- curl \
- nfs-utils-client \
- openssh-scp \
- openssh-sftp \
- pam-plugin-ck-connector \
- \
- bzip2 \
- gdbserver \
- grep \
-# joe \
- ldd \
- mtd-utils \
- update-modules \
- \
- hdparm \
- iperf \
- memtester \
- stress \
- lmbench \
- nbench-byte \
- \
- trdx-nv-binaries \
- ${IMAGE_INSTALL_MACHINE} \
- trdx-config \
- \
- trdx-oak-sensors \
-"
-# tegrastats \
-# gpioconfig \
-# openssl-conf \
-# ntpclient \
diff --git a/recipes/trdx-config/angstrom-feed-configs.bb~ b/recipes/trdx-config/angstrom-feed-configs.bb~
deleted file mode 100644
index fabc334..0000000
--- a/recipes/trdx-config/angstrom-feed-configs.bb~
+++ /dev/null
@@ -1,89 +0,0 @@
-DESCRIPTION = "Configuration files for online package repositories aka feeds"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=aabb"
-
-RRECOMMENDS_${PN} += "opkg"
-
-#PV = "${DISTRO_VERSION}"
-PR = "r15"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FEED_BASEPATH ?= "unstable/feed/"
-
-IWMMXT_FEED = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '',d)}"
-
-do_fetch () {
- echo "MIT" > ${S}/COPYING
-}
-
-do_compile() {
- mkdir -p ${S}/${sysconfdir}/opkg
-
- rm ${S}/${sysconfdir}/opkg/arch.conf || true
- ipkgarchs="${PACKAGE_ARCHS}"
- priority=1
- for arch in $ipkgarchs; do
- echo "arch $arch $priority" >> ${S}/${sysconfdir}/opkg/arch.conf
- priority=$(expr $priority + 5)
- done
-
- for feed in base debug perl python gstreamer ; do
- echo "src/gz ${feed} ${ANGSTROM_URI}/${FEED_BASEPATH}${FEED_ARCH}/${feed}" > ${S}/${sysconfdir}/opkg/${feed}-feed.conf
- done
-
- #trdx: make available the feeds of other, but compatible arm architectures and of the unstable feeds
- echo "src/gz base2 ${ANGSTROM_URI}/feeds/next/ipk/eglibc/armv6/base" >> ${S}/${sysconfdir}/opkg/base-feed.conf
- echo "src/gz base3 ${ANGSTROM_URI}/feeds/next/ipk/eglibc/armv5te/base" >> ${S}/${sysconfdir}/opkg/base-feed.conf
- echo "src/gz base4 ${ANGSTROM_URI}/feeds/unstable/ipk/glibc/armv6/base" >> ${S}/${sysconfdir}/opkg/base-feed.conf
- echo "src/gz base5 ${ANGSTROM_URI}/feeds/unstable/ipk/glibc/armv5te/base" >> ${S}/${sysconfdir}/opkg/base-feed.conf
-
- echo "src/gz ${MACHINE_ARCH} ${ANGSTROM_URI}/${FEED_BASEPATH}${FEED_ARCH}/machine/${MACHINE_ARCH}" > ${S}/${sysconfdir}/opkg/${MACHINE_ARCH}-feed.conf
- echo "#src/gz sdk ${ANGSTROM_URI}/${FEED_BASEPATH}sdk" > ${S}/${sysconfdir}/opkg/sdk-feed.conf
- echo "src/gz no-arch ${ANGSTROM_URI}/${FEED_BASEPATH}all" > ${S}/${sysconfdir}/opkg/noarch-feed.conf
-
- # iwmmxt is a special case, add the iwmmxt feed for machine that have 'iwmmxt' in MACHINE_FEATURES
- if [ "${IWMMXT_FEED}" = "iwmmxt" ] ; then
- echo "src/gz iwmmxt ${ANGSTROM_URI}/${FEED_BASEPATH}iwmmxt/base" > ${S}/${sysconfdir}/opkg/iwmmxt-feed.conf
- fi
-
-
- for localepkg in a af am an ang ar as ast ay az be bg bn br bs byn ca co crh cs csb cy da de dv dz el en eo es et eu fa ff fi fo fr fur fy ga gd gez gl gn gu gv ha haw he hi hr hsb ht hu hy ia id ig io is it iu iw ja ka kk kl km kn ko kok ks ku kw ky la lg li lo locale lt lv mai mg mi mk ml mn mr ms mt mvo my nb ne nl nn no nr nso oc om or pa pap pis pl ps pt qu ro ru rw sa sd se si sid sk sl so sp sq sr ss st sv sw syr ta te tet tg th ti tig tk tl tn tpi tr ts tt ug uk ur uz ve vi wa wal wo xh yi yo zh zu ; do
- echo "src/gz locale-${localepkg}-feed ${ANGSTROM_URI}/${FEED_BASEPATH}${FEED_ARCH}/locales/${localepkg}" > ${S}/${sysconfdir}/opkg/locale-${localepkg}-feed.conf
- done
-}
-
-
-do_install () {
- install -d ${D}${sysconfdir}/opkg
- install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
-}
-
-FILES_${PN} = "${sysconfdir}/opkg/base-feed.conf \
- ${sysconfdir}/opkg/debug-feed.conf \
- ${sysconfdir}/opkg/perl-feed.conf \
- ${sysconfdir}/opkg/python-feed.conf \
- ${sysconfdir}/opkg/gstreamer-feed.conf \
- ${sysconfdir}/opkg/${MACHINE_ARCH}-feed.conf \
- ${sysconfdir}/opkg/noarch-feed.conf \
- ${sysconfdir}/opkg/iwmmxt-feed.conf \
- ${sysconfdir}/opkg/sdk-feed.conf \
- ${sysconfdir}/opkg/arch.conf \
- "
-
-
-CONFFILES_${PN} += "${sysconfdir}/opkg/base-feed.conf \
- ${sysconfdir}/opkg/debug-feed.conf \
- ${sysconfdir}/opkg/perl-feed.conf \
- ${sysconfdir}/opkg/python-feed.conf \
- ${sysconfdir}/opkg/gstreamer-feed.conf \
- ${sysconfdir}/opkg/${MACHINE_ARCH}-feed.conf \
- ${sysconfdir}/opkg/noarch-feed.conf \
- ${sysconfdir}/opkg/sdk-feed.conf \
- ${sysconfdir}/opkg/arch.conf \
- "
-
-python populate_packages_prepend () {
- etcdir = bb.data.expand('${sysconfdir}/opkg', d)
- do_split_packages(d, etcdir, '^locale-(.*)\.conf$', 'angstrom-locale-%s-config', 'Angstrom feed config for the %s locale', extra_depends='', allow_links=True)
-}
-
diff --git a/recipes/trdx-config/trdx-config.bb~ b/recipes/trdx-config/trdx-config.bb~
deleted file mode 100644
index ce6e1b9..0000000
--- a/recipes/trdx-config/trdx-config.bb~
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "setup files"
-LICENSE = "Public Domain"
-PR = "r2"
-
-inherit update-rc.d
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SRC_URI = " file://inittab \
- file://nvrm_daemon \
- file://COPYING \
- "
-LIC_FILES_CHKSUM = "file://COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
-
-PACKAGES = "${PN}"
-
-FILES_${PN} = "/etc/* ${sysconfdir}"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DEPENDS_${PN} += "update-rc.d"
-RDEPENDS_${PN} += "update-rc.d"
-
-do_install () {
- install -d ${D}/etc/init.d
- install -m 0644 ${WORKDIR}/inittab ${D}/etc/
- install -m 0755 ${WORKDIR}/nvrm_daemon ${D}/etc/init.d
-}
-
-INITSCRIPT_NAME = "nvrm_daemon"
-INITSCRIPT_PARAMS = "defaults 91" \ No newline at end of file