summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-12-17 23:06:41 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2012-12-17 23:06:41 +0100
commited5e0e484a2d61b1e140d2a5509e08086af6cbc9 (patch)
tree5df0ad0d1ec00913de2acff20f0d8ee79c44c74d
parent22617ae59c8e8a6333413da10bd2f8193bb6933e (diff)
firefox: set develper.toradex.com as the homepage
-rw-r--r--recipes-mozilla/firefox/files/distribution.ini19
-rw-r--r--recipes-mozilla/firefox/firefox_10.0.2.bbappend8
2 files changed, 26 insertions, 1 deletions
diff --git a/recipes-mozilla/firefox/files/distribution.ini b/recipes-mozilla/firefox/files/distribution.ini
new file mode 100644
index 0000000..5d4f532
--- /dev/null
+++ b/recipes-mozilla/firefox/files/distribution.ini
@@ -0,0 +1,19 @@
+# Partner Distribution Configuration File
+# Author: Max Krummenacher <max.krummenacher@toradex.com>
+# Make our developer support the default home page
+
+[Global]
+id=High performance, low power computing
+version=
+about=Toradex
+
+[LocalizablePreferences]
+browser.startup.homepage="http://developer.toradex.com"
+
+[BookmarksToolbar]
+item.1.title=Toradex Homepage
+item.1.link=http://www.toradex.com/
+item.1.description=Lots of cool stuff
+item.2.title=Toradex Developer Ressources
+item.2.link=http://developer.toradex.com/
+item.2.description=Lots of cool stuff
diff --git a/recipes-mozilla/firefox/firefox_10.0.2.bbappend b/recipes-mozilla/firefox/firefox_10.0.2.bbappend
index 213e335..fcdc730 100644
--- a/recipes-mozilla/firefox/firefox_10.0.2.bbappend
+++ b/recipes-mozilla/firefox/firefox_10.0.2.bbappend
@@ -1,6 +1,12 @@
-PRINC = "3"
+PRINC = "4"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += "file://alignment.patch \
+ file://distribution.ini \
"
+do_install_append() {
+ install -d ${D}${libdir}/${PN}/distribution
+ install -m 0644 ${WORKDIR}/distribution.ini ${D}${libdir}/${PN}/distribution/
+}
+