summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-04-28 10:01:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:04:36 +0200
commit3270c5ae6701c17730c7f7573678b021826bcf18 (patch)
tree0db206cb1707bdbc47009a358aafc9a8d6ef00b8
parent0ce53ab2eb60797db70b48087ffbfcc1de85c460 (diff)
connman: blacklist USB gadget devices
Connman gained support for USB gadget. The typical usecase is to use USB gadget for tethering. In this use case the module would be the device sharing the connection to the USB host connected to the module. However, our typical use case in mind for RNDIS is a simple ethernet connection between a development host and the module, hence no need for tethering/routing. This however is not easily doable with connman, since connman tries to have one connection online only. When enabling USB gadget as a normal ethernet device, this typically leads to classic ethernet not being configured since the USB RNDIS connection is already up and running. By blacklisting USB gadget, connman won't touch the device and we can use other means of bringing up the network interface.
-rw-r--r--recipes-connectivity/connman/connman/main.conf97
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend6
2 files changed, 103 insertions, 0 deletions
diff --git a/recipes-connectivity/connman/connman/main.conf b/recipes-connectivity/connman/connman/main.conf
new file mode 100644
index 0000000..950053b
--- /dev/null
+++ b/recipes-connectivity/connman/connman/main.conf
@@ -0,0 +1,97 @@
+[General]
+
+# Set input request timeout. Default is 120 seconds
+# The request for inputs like passphrase will timeout
+# after certain amount of time. Use this setting to
+# increase the value in case of different user
+# interface designs.
+# InputRequestTimeout = 120
+
+# Set browser launch timeout. Default is 300 seconds
+# The request for launching a browser for portal pages
+# will timeout after certain amount of time. Use this
+# setting to increase the value in case of different
+# user interface designs.
+# BrowserLaunchTimeout = 300
+
+# Enable background scanning. Default is true.
+# Background scanning will start every 5 minutes unless
+# the scan list is empty. In that case, a simple backoff
+# mechanism starting from 10s up to 5 minutes will run.
+# BackgroundScanning = true
+
+# List of Fallback timeservers separated by ",".
+# These timeservers are used for NTP sync when there are
+# no timeserver set by the user or by the service.
+# These can contain mixed combination of fully qualified
+# domain names, IPv4 and IPv6 addresses.
+# FallbackTimeservers =
+
+# List of fallback nameservers separated by "," used if no
+# nameservers are otherwise provided by the service. The
+# nameserver entries must be in numeric format, host
+# names are ignored.
+# FallbackNameservers =
+
+# List of technologies that are marked autoconnectable
+# by default, separated by commas ",". The default value
+# for this entry when empty is ethernet,wifi,cellular.
+# Services that are automatically connected must have been
+# set up and saved to storage beforehand.
+# DefaultAutoConnectTechnologies =
+
+# List of preferred technologies from the most preferred
+# one to the least preferred one separated by commas ",".
+# Services of the listed technology type will be tried one
+# by one in the order given, until one of them gets connected
+# or they are all tried. A service of a preferred technology
+# type in state 'ready' will get the default route when
+# compared to another preferred type further down the list
+# with state 'ready' or with a non-preferred type; a service
+# of a preferred technology type in state 'online' will get
+# the default route when compared to either a non-preferred
+# type or a preferred type further down in the list.
+# PreferredTechnologies =
+
+# List of blacklisted network interfaces separated by ",".
+# Found interfaces will be compared to the list and will
+# not be handled by connman, if their first characters
+# match any of the list entries. Default value is
+# vmnet,vboxnet,virbr,ifb.
+NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,usb,rndis
+
+# Allow connman to change the system hostname. This can
+# happen for example if we receive DHCP hostname option.
+# Default value is true.
+# AllowHostnameUpdates = true
+
+# Keep only a single connected technology at any time. When a new
+# service is connected by the user or a better one is found according
+# to PreferredTechnologies, the new service is kept connected and all
+# the other previously connected services are disconnected. With this
+# setting it does not matter whether the previously connected services
+# are in 'online' or 'ready' states, the newly connected service is
+# the only one that will be kept connected. A service connected by the
+# user will be used until going out of network coverage. With this
+# setting enabled applications will notice more network breaks than
+# normal. Default value is false.
+# SingleConnectedTechnology = false
+
+# List of technologies for which tethering is allowed separated by ",".
+# The default value is wifi,bluetooth,gadget. Only those technologies
+# listed here are used for tethering. If ethernet tethering is desired,
+# then ethernet should be added to the list. The technologies listed here
+# have to support tethering, currently tethering is implemented for wifi,
+# bluetooth, gadget and ethernet.
+# NOTE that if ethernet tethering is enabled, then a DHCP server is
+# started on all ethernet interfaces. Tethered ethernet should
+# never be connected to corporate or home network as it will disrupt
+# normal operation of these networks. Due to this ethernet is not
+# tethered by default. Do not activate ethernet tethering unless you
+# really know what you are doing.
+# TetheringTechnologies = wifi,bluetooth,gadget
+
+# Restore earlier tethering status when returning from offline mode,
+# re-enabling a technology, and after restarts and reboots.
+# Default value is false.
+# PersistentTetheringMode = false
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
index 851b00d..60edc3b 100644
--- a/recipes-connectivity/connman/connman_%.bbappend
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -2,4 +2,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/connman:"
SRC_URI += " \
file://dont_start_connman_on_nfsboot.patch \
+ file://main.conf \
"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/connman/
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/
+}