summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-15 16:28:58 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-22 10:04:19 +0200
commit5c0da5e5a944b19e3f33c88d761c1ed63c8fc68b (patch)
tree9cf0ecbaf1be082f921d74c0865debbe94a7c48b
parent3e832ce32fdbfbbde374d9f5c8c336b8dd1d284f (diff)
x-window-simple-app: create common inc file and rename recipe
Pull out common code so that the bb file only contains information about the application which is to be started. Rename the recipe so that one knows what is going to be started. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb9
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-simple-app.inc (renamed from recipes-graphics/x-window-simple-app/x-window-simple-app_1.0.bb)3
-rw-r--r--recipes-images/images/qt5-x11-image.bb5
3 files changed, 11 insertions, 6 deletions
diff --git a/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
new file mode 100644
index 0000000..2e44da9
--- /dev/null
+++ b/recipes-graphics/x-window-simple-app/x-window-qtsmarthome_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be started
+
+RDEPENDS ?= "qtsmarthome"
+INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0"
+X_APPLICATION ?= "${INITIAL_PATH}/smarthome"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-simple-app_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
index 1bfb7e2..2c5ecc1 100644
--- a/recipes-graphics/x-window-simple-app/x-window-simple-app_1.0.bb
+++ b/recipes-graphics/x-window-simple-app/x-window-simple-app.inc
@@ -13,9 +13,6 @@ inherit allarch
S = "${WORKDIR}"
-INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0"
-X_APPLICATION ?= "${INITIAL_PATH}/smarthome"
-
SRC_URI = " \
file://x-window-manager.in \
file://set_have_touch.sh \
diff --git a/recipes-images/images/qt5-x11-image.bb b/recipes-images/images/qt5-x11-image.bb
index 9a2a911..b0d9ce5 100644
--- a/recipes-images/images/qt5-x11-image.bb
+++ b/recipes-images/images/qt5-x11-image.bb
@@ -3,7 +3,7 @@ SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
DESCRIPTION = "Image with the Qt5 Framework and the X11 server"
# after the boot systemd starts X and then a qt5 application, check
-# recipes-graphics/x-window-simple-app/x-window-simple-app and
+# recipes-graphics/x-window-simple-app/x-window-qtsmarthome and
# https://developer.toradex.com/knowledge-base/how-to-autorun-application-at-the-start-up-in-linux#X11_with_One_User_Application
# for how this is done.
@@ -136,8 +136,7 @@ GSTREAMER_append_tegra124 = " \
IMAGE_INSTALL_QT5 = " \
packagegroup-qt5 \
liberation-fonts \
- qtsmarthome \
- x-window-simple-app \
+ x-window-qtsmarthome \
"
IMAGE_INSTALL_append_tegra124 = " \