summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-04-20 12:51:39 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:04:36 +0200
commitbe158c8c1a71194e5aeeeeb3cc2150bfc564bdac (patch)
tree8caba25d95a8ad2d2c11a99818cb9e8953e8a8e4
parent43e466f7ace70169fdef4d94f23ba3264d8f07aa (diff)
linux-toradex-fsl_git.bb: remove 3.0.15 Vybrid Kernel
This removes the 3.0.15 based Kernel for Colibri VFxx. Since some time now we use a more recent Kernel provided from the linux-toradex-vf_3.18.bb recipe.
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb25
1 files changed, 3 insertions, 22 deletions
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index 7173beb..2932684 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Linux Kernel for Toradex Freescale based modules"
+SUMMARY = "Linux Kernel for Toradex Freescale i.MX6 based modules"
SECTION = "kernel"
LICENSE = "GPLv2"
@@ -9,23 +9,19 @@ require recipes-kernel/linux/linux-dtb.inc
DEPENDS += "lzop-native "
-LINUX_VERSION_colibri-vf = "3.0.15"
LINUX_VERSION_mx6 = "3.10.17"
-SRCREV_colibri-vf = "be731b029cae84453de550058c04841ff99a751b"
-PR_colibri-vf = "V2.3b5"
SRCREV_mx6 = "23b22e549ed6ede5b44a948824463daafb6745c3"
PR_mx6 = "V2.3b5"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
-SRCBRANCH_colibri-vf = "colibri_vf"
-SRCBRANCH_mx6 = "toradex_imx_3.10.17_1.0.0_ga"
+SRCBRANCH_mx6 = "toradex_imx_3.10.17_1.0.0_ga-next"
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
# a Patch
# SRC_URI_append_mx6 += "file://a.patch "
-COMPATIBLE_MACHINE = "(colibri-vf|colibri-imx6|apalis-imx6)"
+COMPATIBLE_MACHINE = "(colibri-imx6|apalis-imx6)"
# Place changes to the defconfig here
config_script () {
@@ -67,18 +63,3 @@ do_compile_kernelmodules() {
bbnote "no modules to compile"
fi
}
-
-#since daisy oe refuses to install headers in /usr/include/linux, install
-#them in /usr/local/include/linux. This is also in gcc's default include paths
-PACKAGES =+ "kernel-fsl-headers-dev"
-FILES_kernel-fsl-headers-dev = "${prefix}/local/include/linux/"
-do_install_append_colibri-vf() {
- #install vybrid specific headers with definitions used for userspace interaction
- install -d ${D}/${prefix}/local/include/linux/
- install -m 644 ${S}/include/linux/mvf_sema4.h ${D}/${prefix}/local/include/linux/
-}
-
-python sysroot_stage_all_append () {
- if os.path.isdir("${D}/${prefix}/local/include/linux/"):
- oe.path.copyhardlinktree(d.expand("${D}/${prefix}/local/include/linux/"), d.expand("${SYSROOT_DESTDIR}/${prefix}/local/include/linux/"))
-}