summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-06-16 11:30:17 +0200
committerStefan Agner <stefan.agner@toradex.com>2015-06-16 15:29:51 +0200
commitfcf5557df811ffb47b892cbe5a72afc0620632f8 (patch)
treede3939ce919b77f0c7bcb6b72f06d9dafa9652b2
parent240e9d08a597ab3c09ec2369d5ab6d1ce6b715b0 (diff)
base-files/u-boot-toradex-fw-utils: move MMC unlock
The mmc unlock function causes troubles when using Poky reference distribution since Poky uses the busybox shell: /etc/rc5.d/S09xserver-nodm: /etc/profile.d/fw_unlock_mmc.sh: line 2: syntax error: unexpected "(" This avoids X getting at all. This patch does not solve the underlying problem, but works around it by moving the script to the u-boot-toradex-fw-utils recipe, which is not installed by the Poky images by default.
-rw-r--r--recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh6
-rw-r--r--recipes/base-files/base-files_3.0.14.bbappend7
2 files changed, 0 insertions, 13 deletions
diff --git a/recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh b/recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh
deleted file mode 100644
index 8982640..0000000
--- a/recipes/base-files/base-files/tegra3/fw_unlock_mmc.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-# Give fw_setenv mmcblk0boot1 write permissions
-function fw_setenv() {
- echo 0 > /sys/block/mmcblk0boot1/force_ro
- /sbin/fw_setenv "$@"
- echo 1 > /sys/block/mmcblk0boot1/force_ro
-}
diff --git a/recipes/base-files/base-files_3.0.14.bbappend b/recipes/base-files/base-files_3.0.14.bbappend
index f423488..af82436 100644
--- a/recipes/base-files/base-files_3.0.14.bbappend
+++ b/recipes/base-files/base-files_3.0.14.bbappend
@@ -1,14 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/base-files:"
-SRC_URI_append_tegra3 = "file://fw_unlock_mmc.sh"
-
do_install_append () {
echo "search colibri.net" > ${D}${sysconfdir}/resolv.conf
echo "nameserver 8.8.8.8" >> ${D}${sysconfdir}/resolv.conf
echo "nameserver 8.8.4.4" >> ${D}${sysconfdir}/resolv.conf
}
-
-do_install_append_tegra3() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
-}