summaryrefslogtreecommitdiff
path: root/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-01-07 16:03:22 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-01-09 19:49:58 +0100
commitf4fac16e1033b3f8679b94e258e8c5d276167946 (patch)
treee79fac1b6964f40d82c5a0a91a5bbca08c9d9220 /qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
parent888c731f3867e4f7bdcf851e6d81428295ac57eb (diff)
qt5: do not require meta-qt5
Move all qt5 relevant stuff where it only gets parsed if meta-qt5 is available. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb')
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
new file mode 100644
index 0000000..f6ba46d
--- /dev/null
+++ b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
@@ -0,0 +1,25 @@
+SECTION = "x11/libs"
+SUMMARY = "systemd qtapplication autostart"
+# The license is meant for this recipe and the files it installs.
+# RNDIS is part of the kernel, udhcpd is part of busybox
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit allarch systemd
+
+SRC_URI = " \
+ file://qt5-x11-demo.service \
+ file://qt5-x11-demo-init \
+"
+
+do_install () {
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/qt5-x11-demo-init ${D}/${bindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/qt5-x11-demo.service ${D}${systemd_unitdir}/system
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "qt5-x11-demo.service"