summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-12-18 10:46:56 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2012-12-18 10:46:56 +0100
commit83c849bc97377ba01fce220e65874350daf6cd23 (patch)
tree0e501cafd8b121ec57dcc53c458108ef6bcf1231 /recipes-bsp/u-boot
parent23a1000b08c767aef23c6f110da9ab604756fa60 (diff)
u-boot: remove all modification, they are moved to u-boot git
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.06.bbappend23
1 files changed, 2 insertions, 21 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
index d70c18c..5d6d3bb 100644
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
@@ -1,6 +1,6 @@
# Extends the core u-boot recipe
# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r3"
+PR ="r5"
DEPENDS += "dtc-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
@@ -14,23 +14,10 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
UBOOT_MACHINE_colibri-t20 = "colibri_t20_config"
UBOOT_MACHINE_colibri-t30 = "colibri_t30_config"
-# gitorious git ###################################################################################################
-#FILESPATHPKG =. "git:"
-#S="${WORKDIR}/git"
-#SRC_URI_COLIBRI = "git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-u-boot.git;protocol=git;branch=master \
-# file://u-boot-warning.patch \
-# file://u-boot-board-unused.patch \
-# file://board_stackcorruption_workaround.patch \
-#"
-#SRCREV_COLIBRI = "63c37d9e1d3ea97391576384d237728c44b5e33b"
-#####################################################################################################################
-
-# toradex git ###################################################################################################
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_COLIBRI = "16a9368a88a28252ea1daedc1df03ccc49ea5b22"
-#####################################################################################################################
+SRCREV_COLIBRI = "a364c856e063d8e62d277be1fd051cd3fce0571c"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
@@ -42,15 +29,9 @@ SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-
-#compile with -O2 not -Os as with gcc 4.5 the code does not work
# override the solution passed in from u-boot.inc as we want to set additional flags
EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
-do_configure_append() {
- # sed -i -e 's/-Os/-O2 -fno-ipa-sra -fno-caller-saves -fno-schedule-insns -mno-unaligned-access/' ${S}/config.mk
- sed -i -e 's/-Os/-O2/' ${S}/config.mk
-}
#build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"