summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-12-23 23:03:33 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2017-01-11 20:18:10 +0100
commitf06f9b397b0db891d902eefa54761b37e7d00ec6 (patch)
treef801529a9290cb22620af513ac2eccb8835f3d86 /recipes-connectivity
parentc3fee8cfb96b2ffdf6d608af7746949da6e786b2 (diff)
linuxptp: fix cross compilation not using host headers
Previously my morty build failed as follows: | arm-angstrom-linux-gnueabi-gcc -march=armv7-a -mthumb -mfpu=neon -mfloat-abi =hard --sysroot=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/apalis-tk1-mai nline -Wall -DVER=1.6 -D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -I/ lib/modules/4.8.13/build/usr/include -DHAVE_ONESTEP_SYNC -D_GNU_SOURCE -DHAVE_C LOCK_ADJTIME -DHAVE_ONESTEP_SYNC -O2 -pipe -g -feliminate-unused-debug-types -fd ebug-prefix-map=/data/build/oe_core-V2.7/build/tmp-glibc/work/armv7at2hf-neon-an gstrom-linux-gnueabi/linuxptp/1.6-r0=/usr/src/debug/linuxptp/1.6-r0 -fdebug-pref ix-map=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/x86_64-linux= -fdebug-p refix-map=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/apalis-tk1-mainline= -c -o msg.o msg.c | {standard input}: Assembler messages: | {standard input}:39: Error: bad instruction `bswapq r0' | <builtin>: recipe for target 'msg.o' failed | make: *** [msg.o] Error 1 As it tried using the kernel headers from my Fedora 23 build server located at /lib/modules/4.8.13/build/usr/include. Fix this by no longer calling the incdefs.sh shell script from the makefile. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch29
-rw-r--r--recipes-connectivity/linuxptp/linuxptp_1.6.bbappend6
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch b/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch
new file mode 100644
index 0000000..02dbb23
--- /dev/null
+++ b/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch
@@ -0,0 +1,29 @@
+From 8a4cad5e2f2cbb6a34bdc6e877fe499502b8c4c8 Mon Sep 17 00:00:00 2001
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Fri, 23 Dec 2016 18:12:29 +0100
+Subject: [PATCH] linuxptp: no incdefs using host headers
+
+Avoid using host headers via incdefs.sh shell script.
+
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+---
+
+ makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/makefile b/makefile
+index 8cdbd15..85174b8 100644
+--- a/makefile
++++ b/makefile
+@@ -33,7 +33,7 @@ OBJECTS = $(OBJ) hwstamp_ctl.o phc2sys.o phc_ctl.o pmc.o pmc_common.o \
+ SRC = $(OBJECTS:.o=.c)
+ DEPEND = $(OBJECTS:.o=.d)
+ srcdir := $(dir $(lastword $(MAKEFILE_LIST)))
+-incdefs := $(shell $(srcdir)/incdefs.sh)
++#incdefs := $(shell $(srcdir)/incdefs.sh)
+ version := $(shell $(srcdir)/version.sh $(srcdir))
+ VPATH = $(srcdir)
+
+--
+2.9.3
+
diff --git a/recipes-connectivity/linuxptp/linuxptp_1.6.bbappend b/recipes-connectivity/linuxptp/linuxptp_1.6.bbappend
new file mode 100644
index 0000000..80e126e
--- /dev/null
+++ b/recipes-connectivity/linuxptp/linuxptp_1.6.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://no-incdefs-using-host-headers.patch"
+
+EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
+ EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC ${CFLAGS}'"