summaryrefslogtreecommitdiff
path: root/recipes-devtools/python/python_2.7.%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-09-09 18:56:39 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-01-10 14:59:12 -0800
commit8d0907545442b3e0e7636b27ab01164549519228 (patch)
treed0ea4099618707cbceec6838553ea751aefba1c2 /recipes-devtools/python/python_2.7.%.bbappend
parentf925a2c3f2385ae8c21912d7ede29f2dacab6cfd (diff)
python bbappend: use version wildcard
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-devtools/python/python_2.7.%.bbappend')
-rw-r--r--recipes-devtools/python/python_2.7.%.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python_2.7.%.bbappend b/recipes-devtools/python/python_2.7.%.bbappend
new file mode 100644
index 0000000..28e5d9e
--- /dev/null
+++ b/recipes-devtools/python/python_2.7.%.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/python:"
+
+SRC_URI_remove = "file://avoid_warning_about_tkinter.patch"
+
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[tkinter] = ",,tk"
+PACKAGECONFIG_remove_class-native = "tkinter"
+PACKAGECONFIG_remove_class-nativesdk = "tkinter"
+RDEPENDS_${PN}-tkinter_append += "${@bb.utils.contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
+SRC_URI += " \
+ ${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
+"
+python __anonymous() {
+ if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS', True):
+ if 'tkinter' in d.getVar('PACKAGECONFIG', True):
+ bb.error('Python PACKAGECONFIG tkinter requires tk provided by' \
+ 'meta-oe layer but the layer is not available.')
+}