summaryrefslogtreecommitdiff
path: root/recipes-graphics/unclutter/files
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-07-30 17:24:17 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-01-10 14:59:23 -0800
commitaf9d91990641cc5cc34010b3eb2c0e827e2ec0b2 (patch)
treef23ec136eab7efc183f04a39848c1cc6488a8058 /recipes-graphics/unclutter/files
parenta6623d0739ef086930335292fc25f0f785de21fa (diff)
unclutter: fix compiler warnings
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-graphics/unclutter/files')
-rw-r--r--recipes-graphics/unclutter/files/cross-compile.patch3
-rw-r--r--recipes-graphics/unclutter/files/fix_include_path.patch26
-rw-r--r--recipes-graphics/unclutter/files/fix_missing_int_declarators.patch61
3 files changed, 90 insertions, 0 deletions
diff --git a/recipes-graphics/unclutter/files/cross-compile.patch b/recipes-graphics/unclutter/files/cross-compile.patch
index 574f9cc..f1277f5 100644
--- a/recipes-graphics/unclutter/files/cross-compile.patch
+++ b/recipes-graphics/unclutter/files/cross-compile.patch
@@ -1,3 +1,6 @@
+Dont hardcode CC. Thus allow to use a cross-compiler
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
--- unclutter-1.09/Makefile.orig 2007-02-05 23:52:40.000000000 +0100
+++ unclutter-1.09/Makefile 2013-05-14 19:08:13.612112758 +0200
@@ -1,7 +1,6 @@
diff --git a/recipes-graphics/unclutter/files/fix_include_path.patch b/recipes-graphics/unclutter/files/fix_include_path.patch
new file mode 100644
index 0000000..618cee8
--- /dev/null
+++ b/recipes-graphics/unclutter/files/fix_include_path.patch
@@ -0,0 +1,26 @@
+Remove include path to /usr/include.
+Fixes bitbake warning:
+| WARNING: unclutter-1.09-r0 do_package_qa: QA Issue: unclutter: The compile log indicates that host include and/or library paths were used.
+| Please check the log '/mnt/sdc2/oe-disk/oe-core_master/build/out-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/unclutter/1.09-r0/temp/log.do_compile' for more information. [compile-host-path]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+diff -Naur unclutter-1.09.orig/Makefile unclutter-1.09/Makefile
+--- unclutter-1.09.orig/Makefile 2016-07-30 16:43:56.730859141 +0200
++++ unclutter-1.09/Makefile 2016-07-30 16:49:19.603890691 +0200
+@@ -10,7 +10,7 @@
+ MFLAGS = -$(MAKEFLAGS)
+ INSTPGMFLAGS = -c -s
+ INSTMANFLAGS = -c
+- TOP_INCLUDES = -I$(INCROOT)
++ TOP_INCLUDES =
+ CDEBUGFLAGS = -O
+ ALLINCLUDES = $(STD_INCLUDES) $(TOP_INCLUDES) $(INCLUDES) $(EXTRA_INCLUDES)
+ ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(PROTO_DEFINES) $(DEFINES) $(COMPATFLAGS)
+@@ -21,7 +21,6 @@
+ IRULESRC = $(CONFIGDIR)
+ IMAKE_CMD = $(IMAKE) -DUseInstalled -I$(IRULESRC) $(IMAKE_DEFINES)
+ BINDIR = $(DESTDIR)/usr/bin/X11
+- INCROOT = $(DESTDIR)/usr/include
+ MANPATH = $(DESTDIR)/usr/catman/x11_man
+ MANSOURCEPATH = $(MANPATH)/man
+ MANDIR = $(MANSOURCEPATH)1
diff --git a/recipes-graphics/unclutter/files/fix_missing_int_declarators.patch b/recipes-graphics/unclutter/files/fix_missing_int_declarators.patch
new file mode 100644
index 0000000..f2acc6a
--- /dev/null
+++ b/recipes-graphics/unclutter/files/fix_missing_int_declarators.patch
@@ -0,0 +1,61 @@
+Modern C compiler warn about the usage of declaring variables with out type
+which then default to int.
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+--- unclutter-1.09.orig/unclutter.c 2007-02-06 00:13:12.000000000 +0100
++++ unclutter-1.09/unclutter.c 2016-07-30 16:44:37.462489217 +0200
+@@ -37,14 +37,15 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xproto.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "vroot.h"
+
+ char *progname;
+-pexit(str)char *str;{
++int pexit(str)char *str;{
+ fprintf(stderr,"%s: %s\n",progname,str);
+ exit(1);
+ }
+-usage(){
++void usage(void){
+ pexit("usage:\n\
+ -display <display>\n\
+ -idle <seconds> time between polls to detect idleness.\n\
+@@ -87,7 +88,7 @@
+ * return true if window has a wm_name and the start of it matches
+ * one of the given names to avoid
+ */
+-nameinlist(display,window)
++int nameinlist(display,window)
+ Display *display;
+ Window window;
+ {
+@@ -109,7 +110,7 @@
+ * return true if window has a wm_name and one of the given names to avoid
+ * matches anywhere in that string
+ */
+-matchinlist(display,window)
++int matchinlist(display,window)
+ Display *display;
+ Window window;
+ {
+@@ -131,7 +132,7 @@
+ /*
+ * create a small 1x1 cursor with all pixels masked out on the given screen.
+ */
+-createnullcursor(display,root)
++Cursor createnullcursor(display,root)
+ Display *display;
+ Window root;
+ {
+@@ -155,7 +156,8 @@
+ return cursor;
+ }
+
+-main(argc,argv)char **argv;{
++int main(argc,argv)
++int argc; char **argv;{
+ Display *display;
+ int screen,oldx = -99,oldy = -99,numscreens;
+ int doroot = 0, jitter = 0, idletime = 5, usegrabmethod = 0, waitagain = 0,