summaryrefslogtreecommitdiff
path: root/recipes-graphics/vnc/tightvnc/Makefile
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:46:59 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:48:26 +0200
commitfa935091a733be1c6d472ef36dab2374887d4497 (patch)
treeabfa2006775340fed265adbe2df5d37423289c96 /recipes-graphics/vnc/tightvnc/Makefile
parentda5646995614d88ad151b82da2072ed51f7ef0cd (diff)
vnc: add directvnc and tightvnc recipes
Two popular VNC clients: - DirectVNC based on DirectFB (e.g. without X11) - TightVNC based on X11 (cherry picked from commit ef4113208de357a5b8accd7610f8bf3230125a59)
Diffstat (limited to 'recipes-graphics/vnc/tightvnc/Makefile')
-rw-r--r--recipes-graphics/vnc/tightvnc/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-graphics/vnc/tightvnc/Makefile b/recipes-graphics/vnc/tightvnc/Makefile
new file mode 100644
index 0000000..3f720f8
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc/Makefile
@@ -0,0 +1,24 @@
+OBJS = argsresources.o \
+caps.o \
+colour.o \
+cursor.o \
+desktop.o \
+dialogs.o \
+fullscreen.o \
+listen.o \
+misc.o \
+popup.o \
+rfbproto.o \
+selection.o \
+shm.o \
+sockets.o \
+tunnel.o \
+vncviewer.o \
+../libvncauth/vncauth.o \
+../libvncauth/d3des.o
+
+tightvncviewer : $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -lX11 -lXaw6 -ljpeg -lz -lXt -lXmu -lXext -o tightvncviewer
+
+%.o: %.c Makefile
+ $(CC) -c $(CFLAGS) -I. -I../include -I../libvncauth/ -o $@ $<