summaryrefslogtreecommitdiff
path: root/recipes-graphics/vnc/tightvnc_1.3.10.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:46:59 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:48:26 +0200
commitfa935091a733be1c6d472ef36dab2374887d4497 (patch)
treeabfa2006775340fed265adbe2df5d37423289c96 /recipes-graphics/vnc/tightvnc_1.3.10.bb
parentda5646995614d88ad151b82da2072ed51f7ef0cd (diff)
vnc: add directvnc and tightvnc recipes
Two popular VNC clients: - DirectVNC based on DirectFB (e.g. without X11) - TightVNC based on X11 (cherry picked from commit ef4113208de357a5b8accd7610f8bf3230125a59)
Diffstat (limited to 'recipes-graphics/vnc/tightvnc_1.3.10.bb')
-rw-r--r--recipes-graphics/vnc/tightvnc_1.3.10.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-graphics/vnc/tightvnc_1.3.10.bb b/recipes-graphics/vnc/tightvnc_1.3.10.bb
new file mode 100644
index 0000000..39297a0
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc_1.3.10.bb
@@ -0,0 +1,43 @@
+DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
+HOMEPAGE = "http://www.tightvnc.com/"
+SECTION = "utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://../LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
+
+DEPENDS = "virtual/libx11 zlib libxmu libxaw jpeg libxt libxext libxmu"
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.bz2 \
+ file://Makefile \
+ file://Vncviewer"
+
+S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
+
+PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
+FILES_${PN}-viewer-dbg = "${bindir}/.debug"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
+
+do_compile () {
+ install ${WORKDIR}/Makefile ${S}
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${PN}viewer ${D}${bindir}
+ install -d ${D}${sysconfdir}/X11/app-defaults
+ install -m 644 ${WORKDIR}/Vncviewer ${D}${sysconfdir}/X11/app-defaults/Vncviewer
+}
+
+pkg_postinst_${PN}-viewer () {
+ update-alternatives --install ${bindir}/vncviewer vncviewer tightvncviewer 100
+}
+
+
+pkg_prerm_${PN}-viewer () {
+ update-alternatives --remove ${bindir}/vncviewer vncviewer tightvncviewer 100
+}
+
+SRC_URI[md5sum] = "397b35faad32d5246b6d44b142f8304f"
+SRC_URI[sha256sum] = "f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d"