summaryrefslogtreecommitdiff
path: root/recipes-images/images/console-tdx-image.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-16 19:51:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-22 10:04:19 +0200
commit2e99a4017a3bc92402ecac9afc3159d29ba637aa (patch)
tree39358dd0df13410e2d6606011a15058cd38639d6 /recipes-images/images/console-tdx-image.bb
parent0d02e0bd8b423c642cec0e997ceadd89ffb9a0de (diff)
images: cleanup
packagegroup-base-extended is installed by inheriting core-image. packagegroup-basic installs dropbear, openssh-sftp, openssh-sftp-server dropbear can act as an scp client, drop openssh-scp Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-images/images/console-tdx-image.bb')
-rw-r--r--recipes-images/images/console-tdx-image.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-images/images/console-tdx-image.bb b/recipes-images/images/console-tdx-image.bb
index fa9cc73..90c35ca 100644
--- a/recipes-images/images/console-tdx-image.bb
+++ b/recipes-images/images/console-tdx-image.bb
@@ -4,6 +4,8 @@ DESCRIPTION = "Image without graphical interface"
LICENSE = "MIT"
+inherit core-image
+
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "Console-Image"
MACHINE_NAME ?= "${MACHINE}"
@@ -32,7 +34,6 @@ IMAGE_INSTALL += " \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
- packagegroup-base-extended \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
'weston weston-examples', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
@@ -46,5 +47,3 @@ IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "busybox shadow"
-
-inherit core-image