summaryrefslogtreecommitdiff
path: root/recipes-images/images/graphical-tdx-image.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-12-02 18:46:45 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-01-09 19:49:47 +0100
commit799543474481325b72d3032a3b456ef635e9eb04 (patch)
tree2217ae0affcc9f21c180b830fd0982621c09ae13 /recipes-images/images/graphical-tdx-image.bb
parentdddc4b9e88e861afa2cfe61660c8d294c622da8d (diff)
images: add a new console/graphical/verification image
This is meant to replace the current demo images. The console and graphical image can be used as a base to create tailored images to the requirment of a specific use case. The verification image is meant to test the BSP. It provides the tools to exercise the CPU / GPU / VPU and the various SOC peripherals. Related-to: ELB-1284 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-images/images/graphical-tdx-image.bb')
-rw-r--r--recipes-images/images/graphical-tdx-image.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-images/images/graphical-tdx-image.bb b/recipes-images/images/graphical-tdx-image.bb
new file mode 100644
index 0000000..b472701
--- /dev/null
+++ b/recipes-images/images/graphical-tdx-image.bb
@@ -0,0 +1,26 @@
+require console-tdx-image.bb
+
+SUMMARY = "Toradex Embedded Linux Graphical Image"
+SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
+DESCRIPTION = "Image with a graphical interface, either using weston or X11"
+
+LICENSE = "MIT"
+
+#Prefix to the resulting deployable tarball name
+export IMAGE_BASENAME = "Graphical-Image"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+IMAGE_FEATURES += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
+ '', d), d)} \
+"
+
+IMAGE_INSTALL += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
+ 'weston weston-init weston-examples wayland-terminal-launch', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
+ 'weston-xwayland xterm', \
+ bb.utils.contains('DISTRO_FEATURES', 'x11', 'x-window-xterm', '', d), d)} \
+"